The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php.ini automatically overwritten upload_max_filesize & post_max_size php.ini file

Discussion in 'General Discussion' started by Smaily, Jul 30, 2013.

  1. Smaily

    Smaily Well-Known Member

    Joined:
    Sep 19, 2011
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I have tried changing upload_max_filesize and post_max_size php.ini file multiple times higher to 250MB but somewhat over time it gets reset to 50MB. How to change it so it wont change back?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Are you attempting to modify the value for your system PHP configuration, or for the internal cPanel PHP configuration? What method are you using to modify the value?

    Thank you.
     
  3. Smaily

    Smaily Well-Known Member

    Joined:
    Sep 19, 2011
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Im aiming in higher upload limit in phpMyAdmin,
    I changed following values which seemed to work but over time they get overwritten back to default.
    /usr/local/cpanel/3rdparty/etc/phpmyadmin/php.ini
    /usr/local/cpanel/3rdparty/etc/php.ini
    /usr/local/lib/php.ini

    I also have set these values in WHM php.ini (this one does not get overwritten but has no impact to phpMyAdmin.
     
  4. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    After editing /usr/local/cpanel/3rdparty/etc/phpmyadmin/php.ini or /usr/local/cpanel/3rdparty/etc/php.ini
    did you run:

    As it states on top of both files:
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can browse to the "PHP" tab in "WHM Home » Server Configuration » Tweak Settings" and modify the following options:

    cPanel PHP max POST size
    cPanel PHP max upload size

    This will ensure the value is reflected and preserved in /usr/local/cpanel/3rdparty/etc/phpmyadmin/php.ini.

    Thank you.
     
Loading...

Share This Page