markitzero

Registered
Aug 28, 2017
1
0
1
UK
cPanel Access Level
Root Administrator
Hello,



It's not currently possible to modify the PHP configuration values for domain names assigned the PHP-FPM handler by using the MultiPHP INI Editor. Instead, you'd need to follow the instructions referenced on the following post:

Enabling PHP-FPM in MultiPHP Manager



Please note the following entry in the cPanel 66 Release Notes:



Thank you.
Could the online documentation be updated to reflect that local.ini files are no longer used?

I upgraded to EasyApache 4 today, and spent a fair amount of time trying to work out why local.ini files weren't appearing as the documentation suggested.

Also, the PECL installer is still looking for local.ini files. It throws up a warning at the end of the install process that local.ini cannot be found. (APCu is an example).
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,250
463
Hello,

Here's a post that further explains how the differences could affect custom PHP configuration values:

cPanel 66 Update MultiPHP INI Editor Changes

Here are links to the updated documents for the cPanel and WHM MultiPHP INI Editor interfaces in version 66 with information about which PHP configuration files are utilized:

MultiPHP INI Editor for cPanel - Version 66 Documentation - cPanel Documentation
MultiPHP INI Editor for WHM - Version 66 Documentation - cPanel Documentation

Also, the PECL installer is still looking for local.ini files. It throws up a warning at the end of the install process that local.ini cannot be found. (APCu is an example).
The intention was to enable PHP extensions by default when you install a PHP PECL extension in WHM's Module Installers interface. However, it looks like this new feature incorrectly utilizes the local.ini file. I've opened internal case CPANEL-15577 to report this issue, and will update this thread with more information on the status of this case as it becomes available. In the meantime, the workaround is to manually add the "extension=module.so" line to the appropriate php.ini file (e.g. /opt/cpanel/ea-php70/root/etc/php.ini) after installing the Pecl module.

Thank you.
 
  • Like
Reactions: Kent Brockman

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,250
463
Hello,

To update, installing a PHP PECL extension in WHM's Module Installers interface no longer uses the local.ini file as of yesterday's EA4 release:

ZC-2834: Stop using local.ini

You can update your system to the latest EA4 RPMs using the "yum update" command if automatic updates are disabled.

Thank you.