Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php.ini directives not working properly

Discussion in 'EasyApache' started by Nurs1927, Nov 2, 2017.

Tags:
  1. Nurs1927

    Nurs1927 Well-Known Member

    Joined:
    Nov 22, 2015
    Messages:
    52
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Hello, I want to activate allow_url_fopen in one domain.

    I used CPanel multiPHP and activated it. The php.ini and .user.ini files are created in root directory, and the .htaccess is modified but.... nothing happen.

    The allow_url_fopen is not activated. it seems that php.ini does not work.

    PHP7
    CentOS7
    EasyApache 4
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,396
    Likes Received:
    1,606
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Nurs1927 likes this.
  3. Nurs1927

    Nurs1927 Well-Known Member

    Joined:
    Nov 22, 2015
    Messages:
    52
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Thank you. I installed suPHP module and select this handler but doesn´t work.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,396
    Likes Received:
    1,606
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    What version of cPanel is installed on this system? Also, did you enable suPHP for the version of PHP associated with this account via the "PHP Handlers" tab in "WHM >> MultiPHP Manager"? Is PHP-FPM enabled for this account?

    Thank you.
     
  5. Nurs1927

    Nurs1927 Well-Known Member

    Joined:
    Nov 22, 2015
    Messages:
    52
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    CPanel 66.0.29
    PHP-FPM Off

    Yes
     
  6. Nurs1927

    Nurs1927 Well-Known Member

    Joined:
    Nov 22, 2015
    Messages:
    52
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    I tested with DSO handler + mod_ruid2, and the directives in .htaccess don´t modify allow_url_fopen
     
  7. Nurs1927

    Nurs1927 Well-Known Member

    Joined:
    Nov 22, 2015
    Messages:
    52
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Okay, I've realized that it's a PHP_INI_SYSTEM directive in PHP7
    Sorry! :oops:
    Can someone tell me the best way to activate it only in a folder. Is it possible to do it with some server configuration?
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,396
    Likes Received:
    1,606
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    System values are not configurable on a per-domain or per-directory basis. You'd need to enable the option globally via "WHM >> MultiPHP INI Editor".

    Thank you.
     
    Nurs1927 likes this.
Loading...

Share This Page