The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php.ini memory_limit keeps resetting itself.

Discussion in 'General Discussion' started by jols, Sep 20, 2009.

  1. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    regarding:

    /usr/local/cpanel/3rdparty/etc/php.ini

    The memory_limit parameter keeps resetting itself back to 128m, I assume when cPanel is upgraded.

    We need to keep this higher for a web builder app we have installed on the server, so is there any way to make our changes stick?
     
  2. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    You do know that PHP.INI only effects plugins in WHM and related and has no bearing on the software and scripts on any of your web hosting accounts, right? :cool:
     
  3. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    Yes. It's a WHM plugin that we are concerned with.
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Did you execute /usr/local/cpanel/bin/install_php_inis after editing the ini file?
     
  5. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    Makes no difference. I just tried that and went back to the php.ini after restarting cpanel. Its back at 128M again. This must be enforced by a setting in the cpanel config somewhere.

    I notice that there is an option to change the cpanel php max execution time in "tweak settings" - but not a setting for memory limit. However, this is most definately being enforced from somewhere. All I have to do is restart cpanel and it reverts back again without fail.
     
  6. factor

    factor Member

    Joined:
    Dec 14, 2002
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    same problem here

    same problem, i'm using centos 5.4 with cpanel release, installed 2 days ago. First there was IO:Socket:SSL missing, solved, and now this.

    Please help us as we migrated server this weekends and lots of our users use this app. We have contacted technical support of web builder (Rvsitebuilder) to see if they can provide a workaround to install anyway, but it's a cpanel bug.

    Thanks in advance for your help.

    Regards,
     
  7. donneo2000

    donneo2000 Member

    Joined:
    May 23, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Any update on this? I have the same problem. I had the same problem with the max_execution_time. Solved this by editing the value from WHM tweak settings. Is there any option in WHM to change memorylimit value as well? Please help!!
     
  8. ppw

    ppw Registered

    Joined:
    Jul 18, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem in a cPanel 11.24.5-R38506 - WHM 11.24.2 - X 3.9
    CENTOS 5.4 x86_64 virtuozzo.

    Around this, are the files
    /usr/local/cpanel/3rdparty/etc/php.ini.dist
    /usr/local/cpanel/3rdparty/etc/php.ini.keep
    related?

    Regards
     
  9. stormchaser

    stormchaser Member

    Joined:
    Jun 29, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lubbock, TX
    I'm having this exact same situation happening as well. I changed the php.ini, saved it, then reopened it to verify the change, yes it's there. Restart cpanel and check it again, it's back to 128M
     
  10. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    Same issue here. We require an increase of memory for webmail usage. I have also tried chattr'ing the file and it is still getting reset to 128mbs. How is this corrected?

    Running latest stable build.

    *Updating "php.ini.dist" with the increase resolves this.
     
Loading...

Share This Page