The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php.ini on user folder

Discussion in 'General Discussion' started by alex2k, Dec 30, 2007.

  1. alex2k

    alex2k Active Member

    Joined:
    Sep 10, 2001
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Recently I update to Apache 2.2.6 and PHP 5.2.5 with suPHP enable.
    By default my php setting set register_global Off also Zend Optimizer v3.3.0 & ionCube PHP Loader v3.1.32 enable.

    It's working fine... but one of my script require register_global On and Zend Optimizer, so I put php.ini on directory where script installed contains:
    Code:
    register_globals = On
    
    I saw in phpinfo register global set On with that option but Zend Optimizer is N/A anymore in there :(
    Because my script also need Zend Optimizer.
    How to include Zend Optimizer in custom php.ini ?

    Thank you for any help.....
     
    #1 alex2k, Dec 30, 2007
    Last edited: Dec 30, 2007
  2. WebScHoLaR

    WebScHoLaR Well-Known Member

    Joined:
    Dec 14, 2005
    Messages:
    511
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Planet Earth
    The best option is to copy the /usr/local/lib/php.ini to the user account and turn register_gloabals ON in it. In this way all server level php settings will be applied to that user with his custom.
     
  3. little_oak

    little_oak Member

    Joined:
    Jul 19, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Don't work!

    It's don't work.
    My configure:

    apache 2.2.6,
    php 5.2.5 (fastcgi),
    processor intel,

    tried subscribe .htaccess (don't work)
    cp php.ini (master) to account (don't work)
    Anybody know problem?
    Thanks!
     
Loading...

Share This Page