The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Php.ini problem on modernbill installing

Discussion in 'General Discussion' started by neo4242002, Jan 5, 2006.

  1. neo4242002

    neo4242002 Well-Known Member

    Joined:
    Jun 28, 2005
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    I need to install modernbill for one of my client without changing anything in master php.ini file. I have not install phpsuexec.

    can i use followings in .htaccess ?

    error_reporting = 2039
    magic_quotes_gpc = On
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off
    memory_limit = 32M
    open_basedir = no value
    register_argc_argv = On
    register_globals = On
    register_long_arrays = On
    short_open_tag = On
    safe_mode = Off
     
  2. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    The .htaccess file that comes with ModernBill has most of that in it already.
     
  3. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    Casey's post is indeed correct but adding to a .htaccess is somewhat different to adding to a php.ini file. Here is how your list should look in .htaccess format.

    php_value "magic_quotes_gpc" "1"
    php_value "register_globals" "1"
    php_value "error_reporting" "2039"
    php_value "magic_quotes_runtime" "1"
    php_value "magic_quotes_sybase" "1"
    php_value "memory_limit" = "32M"
    php_value "open_basedir" "0"
    php_value "register_argc_argv" "1"
    php_value "register_long_arrays" "1"
    php_value "short_open_tag" "1"
    php_value "safe_mode" "0"

    I believe you should be able to include the ones missing in the MB install .htaccess.

    :)
     
  4. neo4242002

    neo4242002 Well-Known Member

    Joined:
    Jun 28, 2005
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Hi Izzee,, thanks i am going to test these now. but i did not get what that you mean "I believe you should be able to include the ones missing in the MB install .htaccess."

    in fact what do you mean by "ones missing in the MB install .htaccess" anyway?
     
  5. neo4242002

    neo4242002 Well-Known Member

    Joined:
    Jun 28, 2005
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Sorry Izzee, that generate following error. anyway help?


    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@outscopehosting.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
     
  6. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    You may first wish to use the .htaccess file included in the Modern Bill install.

    Then if your install goes ahead without problems try adding the directives that are not included in the installed .htaccess file, one at a time in to the same MB .htaccess file. This will indicate which directive is giving errors.

    Also the ModernBill support facility should really be consulted to give you help with this as it is not really a cPanel issue.

    :)
     
    #6 Izzee, Jan 5, 2006
    Last edited: Jan 5, 2006
  7. neo4242002

    neo4242002 Well-Known Member

    Joined:
    Jun 28, 2005
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Izzee......

    I found the problem but don't know how to fix it.

    That error only generated when rthe following line in .htaccess... if i remove it, then it is working

    php_value "memory_limit" = "32M"
     
  8. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    My typo sorry. remove the = sign.

    php_value "memory_limit" "32M"

    :)
     
    #8 Izzee, Jan 5, 2006
    Last edited: Jan 5, 2006
  9. neo4242002

    neo4242002 Well-Known Member

    Joined:
    Jun 28, 2005
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Hi Izzee.. thanks indeed.

    It is working perfectly. :D :D

    In fact, can you tell how to do it in php.ini file.... this thread might be useful to others as well?

    Thanks again
     
  10. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    Your original values are fine for php.ini file:

    error_reporting = 2039
    magic_quotes_gpc = On
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off
    memory_limit = 32M
    open_basedir = no value
    register_argc_argv = On
    register_globals = On
    register_long_arrays = On
    short_open_tag = On
    safe_mode = Off

    They will be already in your main php.ini file and all you would do is edit the value to suit your requirements.

    Take a look at /usr/local/Zend/etc/php.ini file or where ever your main php.ini file is located.

    In shell type:

    locate php.ini
     
  11. neo4242002

    neo4242002 Well-Known Member

    Joined:
    Jun 28, 2005
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Thank you very much.. That was a really quick reply..

    but i do not want to change my master php.ini file.. How about custom php.ini file in public_html folder?

    I have not enable phpsuexec. in my server. but I have install zend.. but I do not want to change my master php setting... would it possible to use php.ini file with my current setting above
     
  12. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    If you use phpSuexec then you must use a php.ini file if you want to change the behaviour of the master php.ini settings on a client by client basis.

    If no phpSuexec then you can only use a .htaccess file to change the behaviour of the master php.ini file on a client by client basis. These are placed in the directory that a script like MB is called from. So if the script is in a subdirectory then you place either one in the subdirectory.

    :)
     
    #12 Izzee, Jan 6, 2006
    Last edited: Jan 6, 2006
  13. neo4242002

    neo4242002 Well-Known Member

    Joined:
    Jun 28, 2005
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Thanks Izzee.. things are now crystal clear .. keep it up your good works :) :)

    Thanks indeed :D
     
  14. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    Thanks and your most welcome. :D

    :)
     
Loading...

Share This Page