The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP INI setting changed after UPCP

Discussion in 'General Discussion' started by techteamus, Aug 24, 2016.

  1. techteamus

    techteamus Registered

    Joined:
    Aug 24, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Phoenix
    cPanel Access Level:
    Website Owner
    Last night I noticed several hundred messages from my cron jobs complaining that the $argv variable was not set. Considering it is a day off I knew I did not change anything. This morning when I was able to investigate the problem I eventually discovered that:

    register_argc_argv = On (The default)

    To:

    register_argc_argv = Off

    Looking back through the emails it all began after the nightly UPCP which contained a version update for WHM to 58 and yum updates for PHP 5.6 and PHP 7.

    To change the software configuration of a server can be very disruptive and I would like to know how this could happen.
     
  2. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    509
    Likes Received:
    64
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    This shouldn't have happened, unless when the change was made, it wasn't made to local.ini, but instead to php.ini. Can you confirm where this change was made?
     
  3. techteamus

    techteamus Registered

    Joined:
    Aug 24, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Phoenix
    cPanel Access Level:
    Website Owner
    Hello Jacob

    /opt/cpanel/ea-php56/root/etc/php.d/local.ini
    /opt/cpanel/ea-php70/root/etc/php.d/local.ini

    Both those contain register_argc_argv = On which I assume is the correct I made through WHM to get things working.

    /opt/cpanel/ea-php56/root/etc/php.ini
    /opt/cpanel/ea-php70/root/etc/php.ini

    Both those contain register_argc_argv = Off.

    Daniel
     
  4. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    509
    Likes Received:
    64
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    That looks correct, local.ini should contain your changes, and the php.ini is what the RPM puts down, and should contain the 'defaults', so to speak.

    Were the original changes put into local.ini as well? I haven't heard of php.ini being overwritten at all, but I can't think of a reason why this would happen, and I wasn't able to replicate it either.

    It might be good to throw in a ticket so we can take a deeper look at this, if you still have a server that was affected.
     
  5. ethix

    ethix Active Member

    Joined:
    Dec 21, 2004
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Australia
    Looks like I had the memory setting in php.ini reset to 32M.

    I am yet to check other servers but this one server somehow had the memory setting reset.
     
Loading...

Share This Page