The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php.ini works in webroot but no subdirectories

Discussion in 'General Discussion' started by section31, Mar 3, 2009.

  1. section31

    section31 Active Member

    Joined:
    Sep 3, 2003
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    San Antonio
    Is there something I need to configure in suphp config file that allows the php.ini file in the user's webroot to apply to all subdirectories. Everytime I drop a php.ini file in a user's webroot, any subdirectory doesn't inherit those settings. Anybody know how i can fix this?
     
  2. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    are you putting a line like this in your .htaccess file?

    suPHP_ConfigPath /home/username/public_html

    or if you don't want the php.ini web accessible

    suPHP_ConfigPath /home/usename
     
  3. section31

    section31 Active Member

    Joined:
    Sep 3, 2003
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    San Antonio
    I wasn't aware I had to do that so no I didn't. Is there anyway I can have it where it defaults to that user web root?
     
Loading...

Share This Page