The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP Issues

Discussion in 'General Discussion' started by kris1351, Apr 11, 2004.

  1. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    We had some issues with customers sites and phpsuexec the other night after pushing it to all servers. We opted to back it out until we could resolve the specific issues we found, but now some customers are complaining that when they access their php page it downloads as source instead of displays. I cannot duplicate it from our machines, but most are saying the Win 98 boxes running IE are seeing this issue.

    Any suggestions? Anything I can run serverside?
     
  2. Planet_Master

    Planet_Master Well-Known Member

    Joined:
    Apr 18, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Yorker
    Maybe recompiling PHP wouild be your best option to ensure everything is on the same page.

    run /scripts/easyapache and choose php 4.3.4 although 4.3.5 is a option now and we are running it without problems on our RHE and RH9 boxes.

    Hopefully cPanel will add 4.3.6RC2 which fixes some bugs in 4.3.5
     
  3. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Yea, I backed it out to 4.3.3 and then re-installed with 4.3.4 and still 98 systems are doing this. I am at a loss as all of our systems are Xp and seeing it fine.
     
  4. Planet_Master

    Planet_Master Well-Known Member

    Joined:
    Apr 18, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Yorker
    Are you running in safe_mode?
     
  5. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    No, have never used safe mode.
     
  6. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Have a look at your httpd.conf file and see if you have these entries.

    # To use CGI scripts:
    #
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php .php4
    AddType application/x-httpd-php .php3
    AddType application/x-httpd-php-source .phps
    AddType application/x-httpd-php .phtml

    If you'd like to share a URL, I can test it with W98 & IE 6.
     
  7. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Yea, all of those are present. Is only 98 users complaining also.
     
  8. oinkmedia

    oinkmedia Well-Known Member

    Joined:
    Jul 5, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    SW London (UK)
    I am experiencing a similar problem. I am running the latest stable version of cPanel and PHP 4.3.9 and cannot get phps files to parse. However, standard php files work fine yet PHP via WAP do not work?

    Stats:

    WHM 9.9.7 cPanel 9.9.8-R5
    Fedora i686 - WHM X v3.1.0

    Apache Core 1.3.33
    Passthrough Authentication 1.8
    Bytes Logger 1.2
    Bandwidth Limiter 1.4
    PHP 4.3.9
    FrontPage 5.0.2.2634a
    mod_ssl 2.8.22
    OpenSSL 0.9.7a

    I have also double checked that my httpd.conf file includes:

    AddType application/x-httpd-php .php
    AddType application/x-httpd-php .php4
    AddType application/x-httpd-php .php3
    AddType application/x-httpd-php-source .phps
    AddType application/x-httpd-php .phtml

    Is there a conflict so where? anyone else experiencing problems?
     
  9. oinkmedia

    oinkmedia Well-Known Member

    Joined:
    Jul 5, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    SW London (UK)
Loading...

Share This Page