The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php mail(); function doesn't work when disabling NOBODY from sending emails

Discussion in 'E-mail Discussions' started by ecwebtechie, Sep 2, 2005.

  1. ecwebtechie

    ecwebtechie Well-Known Member

    Joined:
    Mar 22, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    enable phpsuexec. to send mails from php scripts
     
  2. maaking

    maaking Member

    Joined:
    May 28, 2004
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    When disabling NOBODY from sending emails in:
    WHM>>Tweak Settings>>Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)

    when I disabled it most users complained + they are unable to email their clients especially forum newsletter.
    The php mail function sends emails to localhost email accounts only, but it doesn't send any single email out side the server.

    the question is: how to keep NOBODY blocked and bring PHP Mail(); to work?.
     
  3. maaking

    maaking Member

    Joined:
    May 28, 2004
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    thank you ecwebtechie,

    but where/how to install phpsuexec, when i install it, all php file should be modified and add: #!/usr/local/bin/php in top line?.

    regards
    maaking
     
  4. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    phpsuexec is installed through WHM > Software > Update Apache, or via /scripts/easyapache in SSH.
     
  5. maaking

    maaking Member

    Joined:
    May 28, 2004
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    thank you verymuch :)
     
Loading...

Share This Page