The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php mail() function not sending mail

Discussion in 'E-mail Discussions' started by fuzzymonkey, Feb 23, 2006.

  1. fuzzymonkey

    fuzzymonkey Well-Known Member

    Joined:
    Jun 11, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    I'm putting this in the WHM forum because I used easyapache to configure php with phpsuexec. I have the mail() function enabled in WHM, and this was working for some time, but I have just been alerted that php's mail() function on this server no longer sends emails. I haven't made any changes to apache or php. I'm running php 4.4.2 configured with:

    $ ./configure --with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --enable-ftp --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zlib --with-gd --with-jpeg-dir=/usr/ --with-png-dir=/usr/

    Same script sends emails on other servers, but I have no way of finding out the php version or whether they use phpsuexec.
     
  2. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    Do you have the Tweak Settings - prevent nobody messages from going out? If you do make sure this option is off.
     
  3. fuzzymonkey

    fuzzymonkey Well-Known Member

    Joined:
    Jun 11, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Yes, I'm sorry, I wasn't clear. That's what I meant when I said I had the mail() function enabled in WHM.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Check whether you have a file /etc/eximmailtrap - if that exists, delete it and then edit /var/cpanel/cpanel.config and set eximmailtrap=0
     
Loading...

Share This Page