The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php mail function problem

Discussion in 'E-mail Discussions' started by hasany, Jan 12, 2004.

  1. hasany

    hasany Registered

    Joined:
    Jan 11, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pakistan
    Cpanel is running on my Hosted company, I am getting all mails bounced back to returned path. Please help me out of this confusion.
     
  2. hasany

    hasany Registered

    Joined:
    Jan 11, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pakistan
    php mail function

    I am using server Cpanel installed and it was very much fine with 15 days a ago with mail() function. But from now i am unable to send. Message bouncing is

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    hasan1578@yahoo.com
    unrouteable mail domain "yahoo.com"


    Is there any problem with mail due to Cpanel lastest Update. because i found this issue on a web site please help me in this regard
     
  3. chican0

    chican0 Well-Known Member

    Joined:
    Mar 26, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Los Angeles
    I am receiving this same exact error/problem. Did you find a resolution yet or does anyone have any advice on this issue?
     
  4. ttremain

    ttremain Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    212
    Likes Received:
    0
    Trophy Points:
    16
    If memory serves me correctly... When I had this problem, I had the following:

    phpsuexec enabled
    Tweek Settings "Prevent the user 'nobody' from sending out mail to remote addresses" enabled.

    You must disable one or the other, otherwise without phpsuexec, scripts send as "nobody", but are then not allowed to send mail.
     
  5. chican0

    chican0 Well-Known Member

    Joined:
    Mar 26, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Los Angeles
    Thank you. That was the exact problem. :)

    I have corrected the issue by disabling the tweak of disallowing NOBODY from sending emails.
     
  6. Pie

    Pie Registered

    Joined:
    Aug 31, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem. Can anyone give me a general direction push and tell me which these 2 options are. I see the 'nobody' one but not the other.
     
  7. ttremain

    ttremain Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    212
    Likes Received:
    0
    Trophy Points:
    16
    "Prevent the user 'nobody' from sending out mail to remote addresses" is in treek settings.

    phpsuexec is enabled when compiling Apache.

    If you are using phpsuexec, PHP runs as the user, otherwise it runs as 'nobody'. (phpsuexec however opens some security holes) If you block emails from nobody, and phpsuexec is not in use, many php scripts will break, and not be allowed to send email.
     
  8. Pie

    Pie Registered

    Joined:
    Aug 31, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    K. Got that before. Just how to i use suxec... im unsure where to edit etc.

    on the server, the mail function works on other domains
     
  9. ttremain

    ttremain Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    212
    Likes Received:
    0
    Trophy Points:
    16
    That's done when you compile Apache. From either /scripts/easyapache or in WHM under, "update apache"
     
  10. Valetia

    Valetia Well-Known Member

    Joined:
    Jun 20, 2002
    Messages:
    207
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    If phpSuexec is already enabled, why would the user 'nobody' still be sending out mail? Won't scripts be running under the account userids?
     
  11. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    I have the same problem .. and also have the same question like Valetia here :confused:
     
  12. chican0

    chican0 Well-Known Member

    Joined:
    Mar 26, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Los Angeles
    That should not be happening if you have phpSuExec enabled. If your php scripts are sending as nobody, then it would be a sign that phpsuexec is not enabled. You should verify that is it enabled.
     
  13. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    In my case, i have phpSuexec enabled and double check it through WHM :
    Software >> Update Apache >> Load Previous Config and i saw on below that PHP suEXEC Support enabled (tick).

    But still i must disabled "Prevent the user 'nobody' from sending out mail to remote addresses" from Tweak Setting if i don't want to receive a lot of unrouteable mail domain.

    So .. the question is still the same .. WHY ?
     
Loading...

Share This Page