The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP Mail not working...

Discussion in 'E-mail Discussions' started by mistervlad, Feb 6, 2008.

  1. mistervlad

    mistervlad Member

    Joined:
    Dec 1, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Ok, I just set up my CPanel machine, and I was just testing some of my scripts, and I noticed that the PHP Mail() function is not working?

    This is an odd issue, so I thought lets try the PHPMailer() class, and again, that doesn't work!

    Is there a setting I am missing somewhere? Becuase I am lost, and I dont know where to search!

    The worst part, is that my forum (PHPBB) wont even send out email!

    Mistervlad


    ps. the even funnier thing, is that it will send to local domains on the server, but nothing external of the server, so that may be the issue itself... but where do I look??
     
  2. mohd_007

    mohd_007 Well-Known Member

    Joined:
    Sep 22, 2007
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Website Owner
    Hello,


    Please check the tweak settings in the WHM and check out the option "prevent mail from nobody" I think this will help you.


    Please do not hesitate to contact me if issue persists and update me with the status weather the issue has been resolved or not.

     
  3. mistervlad

    mistervlad Member

    Joined:
    Dec 1, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    in the tweak settings, this is what i have for my mail settings:


    Mail

    Default catch-all/default address behavior for new accounts. fail is usually the best choice if you are getting mail attacks.
    localuser blackhole fail

    Silently Discard all FormMail-clone requests with a bcc: header in the subject line checked

    Number of minutes between mail server queue runs (default is 60).60

    Track the origin of messages sent though the mail server by adding the X-Source headers (exim 4.34+ required) unchecked

    The maximum each domain can send out per hour (0 is unlimited) 0

    Prevent the user "nobody" from sending out mail to remote addresses (PHP and CGI scripts generally run as nobody if you are not using PHPSuexec and Suexec respectively.) unchecked

    Include a list of Pop before SMTP senders in the X-PopBeforeSMTP header when relaying mail. (exim 4.34-30+ required) unchecked

    The number of times users are allowed to check their mail using pop3 per hour. Zero is unlimited. (cppop only) 0

    Attempt to prevent pop3 connection floods checked

    Automatically setup /etc/localdomains, /etc/remotedomains, /etc/secondarymx based on where the mx entry is pointed. checked

    BoxTrapper Spam Trap checked

    Horde Webmail unchecked

    Mailman checked

    SpamAssassin Spam Filter checked

    SpamAssassin Spam Box delivery for messages marked as spam (user configurable) checked

    SquirrelMail Webmail checked

    Add the mail. prefix for mailman urls (ie http://mail.domain.com/mailman)checked
     
  4. mistervlad

    mistervlad Member

    Joined:
    Dec 1, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    OMFG! I am such an idiot...

    I double checked some settings, and looked around for ANYTHING...

    then, for some reason, i was in the WHM, and i checked the mail transport to my other domain (which is hosted elsewhere until this issue was resolved), and it said that it was a local transport!!

    I forgot that i had set up the account, and didn't transfer it over yet... so, that would explain why the email was rejected!

    Wow... sometimes, the littlest thing, takes the longest to find...


    ALL IS GOOD NOW!!! :)

    Mistervlad
     
Loading...

Share This Page