The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php manual compile - need openssl

Discussion in 'General Discussion' started by luxrum, Aug 31, 2011.

  1. luxrum

    luxrum Member

    Joined:
    Feb 28, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hello,


    We are looking forward to enable openssl in out dedicated server. We are afraid to recompile with EASYAPACHE. Since we have application running past 3yrs in the same.

    So, we have decided to manually recompile the php with older config and with openssl now. --- Will this break the cPanel?

    If not from where i can build the php ONLY? Ex php 5.2.17

    Waiting for the replies,


    Thanks
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    We cannot recommend manually compiling PHP on a system with cPanel. EasyApache has been part of cPanel for a very long time and that is the only supported way to compile Apache and PHP on a system.

    Of note, if you have not updated Apache or PHP for 3 years, you likely are running insecure versions of both that would not include any released security updates. As such, it's pretty vital you would upgrade both of them.

    Basically, if you would like to add openssl for PHP, you will need to run EasyApache.
     
Loading...

Share This Page