The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP mysql.so error

Discussion in 'General Discussion' started by BrentH, Mar 19, 2012.

  1. BrentH

    BrentH Registered

    Joined:
    Mar 19, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi, I have been getting this error with email piping for WHMCS. The piping itself works, but will throw this error message back to the sender.



    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20060613/mysql.so' - /usr/lib/php/extensions/no-debug-non-zts-20060613/mysql.so: undefined symbol: PL_perl_destruct_level in Unknown on line 0

    I'm not 100% sure where to go from here with this.

    Some more details:

    Code:
     grep extension /usr/local/lib/php.ini
    ; dynamically loaded extension (either a PHP extension or a Zend extension),
    ; you may only use these constants *after* the line that loads the extension.
    ; leading '/'. You must also specify the file extension being used including
    ; Directory in which the loadable extensions (modules) reside.
    ;extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20090626"
    extension="eaccelerator.so"
    zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.3.so"
    extension = "/usr/lib/php/extensions/no-debug-non-zts-20060613/mysql.so"
    ; If you wish to have an extension loaded automatically, use the following
    ; needs to go here.  Specify the location of the extension with the
    ; extension_dir directive above.
    ; dictionary files.  Include the base filename, but not the file extension.
    zend_extension="/usr/local/Zend/lib/Guard-5.5.0/php-5.3.x/ZendGuardLoader.so"



    Code:
     no-debug-non-zts-20060613]$ ls -l
    total 2536
    -rwxr-xr-x 1 root root 229593 Mar  9 21:50 mysql.so
    -rwxr-xr-x 1 root root 112066 Mar  1 19:35 pdo.a
    -rwxr-xr-x 1 root root  29756 Mar  1 19:35 pdo_mysql.a
    -rwxr-xr-x 1 root root  34717 Mar  1 19:35 pdo_mysql.so
    -rwxr-xr-x 1 root root 114417 Mar  1 19:35 pdo.so
    -rwxr-xr-x 1 root root 579024 Mar  1 19:35 pdo_sqlite.a
    -rwxr-xr-x 1 root root 519754 Mar  1 19:35 pdo_sqlite.so
    -rwxr-xr-x 1 root root 481176 Mar  1 19:35 sqlite.a
    -rwxr-xr-x 1 root root 447539 Mar  1 19:35 sqlite.so
    
    
    At first I was getting an error stating that mysql.so wasn't there. So I cp'ed it from /usr/local/lib... to /usr/lib/...

    Now I'm getting this error. I'm not 100% sure that copying it was the correct thing to do, but I found a similar thread on WHT and that was their solution.

    I'm running:

    WHM 11.30.6
    centOS 5.7 32bit
    LiteSpeed 4.1.11

    The first problem seemed to be that rebuilding php from the litespeed admin panel didn't add mysql.so, so that's why I copied it the first time, then I think I recompiled it or something. I don't recall as it's been a few weeks since I could get back on this issue.

    Any help would be greatly appreciated. I also have some client sites running on the server, so I need to be careful rebuilding and breaking php sites.
     
    #1 BrentH, Mar 19, 2012
    Last edited: Mar 19, 2012
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    cPanel doesn't use mysql.so for PHP's MySQL support nor litespeed in EasyApache (we provide Apache). As such, this sounds like a litespeed question for their support avenues if they require mysql.so for some reason (we wouldn't know as we do not support litespeed). Have you tried contacting them about it?
     
  3. BrentH

    BrentH Registered

    Joined:
    Mar 19, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I haven't tried contacting litespeed yet. I wasn't sure if it was related to litespeed or not. I will contact litespee regarding this issue. Thanks for replying.
     
Loading...

Share This Page