The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP MySQL version

Discussion in 'General Discussion' started by ice53ltd, May 26, 2003.

  1. ice53ltd

    ice53ltd Member

    Joined:
    Sep 12, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I noticed using a PHP info page that my current Client API version for MySQL is 3.23.49.

    The MySQL server I'm running is 3.23.56 and I also have the client libraries for this installed since there is a serious exploit in previous versions.

    How can I force Easyapache to use the MySQL client libraries installed on my system rather than the bundled PHP ones?

    cPanel.net Support Ticket Number:
     
  2. ice53ltd

    ice53ltd Member

    Joined:
    Sep 12, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Problem solved...

    looking in buildscript I found:

    export WITHMYSQL="--with-mysql"
    if [ -e "/usr/local/bin/mysql" ]; then
    export WITHMYSQL="--with-mysql=/usr/local"
    fi
    if [ -e "/usr/bin/mysql" ]; then
    export WITHMYSQL="--with-mysql=/usr"
    fi
    export WITHMYSQL="--with-mysql"

    on lines 218-225. Line 225 shouldn't be there so I commented it out and things worked perfectly.

    DarkORB... you may wish to correct this part of the script.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page