The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php not working after php5 install

Discussion in 'General Discussion' started by Phillis, Oct 31, 2007.

  1. Phillis

    Phillis Member

    Joined:
    Oct 31, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hey..i just used WHM to add php 5 to my server..i wanted ti have both php4 and 5 on it...so during the install i checked both the php4(was checked) and phph5 to install

    after all installs were completed
    php -v shows:
    Code:
    PHP 5.2.4 (cli) (built: Oct 31 2007 15:21:47)
    wich is ok but now none of my websites work and display these errors:

    Code:
    Warning: Unexpected character in input: '' (ASCII=14) state=1 in /usr/local/cpanel/cgi-sys/php4 on line 192
    
    Parse error: syntax error, unexpected T_STRING in /usr/local/cpanel/cgi-sys/php4 on line 192
    Please help i need to fix it ASAP
    Thanks
     
  2. Phillis

    Phillis Member

    Joined:
    Oct 31, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    anyone please ?
     
  3. aracrew

    aracrew Active Member

    Joined:
    Dec 8, 2006
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    try to make easyapache for the apache 1.3.3.9 with php4
     
  4. tangowebs

    tangowebs Well-Known Member

    Joined:
    Oct 12, 2004
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    0
    on WHM version: WHM 11.2.0 cPanel 11.11.0-S18033
    Under Software--> update apache CANT select both php4 and 5... where do u select it?
     
  5. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    You are on STABLE, therefore you do not have EasyApache 3 yet. EasyApache 3 introduced support for concurrent PHP (running PHP 4 and 5 simultaneously) to cPanel/WHM. This will propagate to STABLE as part of the Stage 2 release. For updated information on the ETA for this, please visit:

    http://www.cPanel.net/cpanel11
     
Loading...

Share This Page