The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP Nuke & Oscommerce

Discussion in 'General Discussion' started by SDM, Aug 15, 2003.

  1. SDM

    SDM Registered

    Joined:
    Jul 19, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    What's the chance of getting these add on scripts updated?
    PHP Nuke is not up to 6.7 and oSc just released 2.2 M2, which deals with some security issues, and makes it easer to submit to search engines..

    Thanks

    cPanel.net Support Ticket Number:
     
  2. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
    osCommerce update Script

    It is ugly but it works:

    Update the cPanel scripts to osCommerce 2.2 Milestone 2 (07/12/2003)

    save the file, rename to osco
    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  3. eter4

    eter4 Well-Known Member

    Joined:
    Feb 16, 2002
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    WOW!!

    That works great.

    Thanks

    cPanel.net Support Ticket Number:
     
  4. Curto

    Curto Active Member

    Joined:
    Sep 4, 2003
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    NY, USA
    Doh!

    Firstly, good work on the script...

    My only problem... I ran it exactly as you wrote, and oscommerce now installs without the user permission error I had previously... but it looks for all images in /images instead of ./images .. so on my server it looks for http://<myserver>/images instead of http://<myserver>/osc/images

    Any idea how to fix this other than moving the images into /images ? I've been looking but can't find a option in the oscommerce admin site to change this.

    Regards,
    Michael

    cPanel.net Support Ticket Number:
     
  5. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
    oscommerce install script

    The install script needs to be updated.
    The new version uses:
    so you need to edit the install script:

    Find
     
  6. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    So .. how to update php-nuke script then?
    Anyone knows step by step like oscommerce above would be appreciated if you share it with us :D

    Ah .. yes i almost forget.
    The install script for oscommerce like asmithjr wrote has a little error on product link. Here the correction :

    And the correction :

    Code:
    regsrep("$installdir/includes/configure.php","\\('DIR_WS_HTTP_CATALOG'","define('DIR_WS_HTTP_CATALOG', '$installpath/');");
    regsrep("$installdir/includes/configure.php","\\('DIR_WS_HTTPS_CATALOG'","define('DIR_WS_HTTPS_CATALOG', '$installpath/');");
    
    cPanel.net Support Ticket Number:
     
    #6 isputra, Sep 12, 2003
    Last edited: Sep 12, 2003
  7. Curto

    Curto Active Member

    Joined:
    Sep 4, 2003
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    NY, USA
    hmmm

    Other than his being on 4 lines instead of your 2, what's the difference?

    cPanel.net Support Ticket Number:
     
  8. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    Code from asmithjr :

    Code:
    regsrep("$installdir/includes/configure.php","\\('DIR_WS_HTTP_CATALOG'","define('DIR_WS_CATALOG', '$installpath/');");
    regsrep("$installdir/includes/configure.php","\\('DIR_WS_HTTPS_CATALOG'","define('DIR_WS_CATALOG', '$installpath/');");
    
    And the correction :

    Code:
    regsrep("$installdir/includes/configure.php","\\('DIR_WS_HTTP_CATALOG'","define('DIR_WS_HTTP_CATALOG', '$installpath/');");
    regsrep("$installdir/includes/configure.php","\\('DIR_WS_HTTPS_CATALOG'","define('DIR_WS_HTTPS_CATALOG', '$installpath/');");
    
    See the difference ? :D

    cPanel.net Support Ticket Number:
     
  9. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
    thanks for the osc update

    I see i put the wrong script in. Thanks for catching it for this update.

    cPanel.net Support Ticket Number:
     
  10. Curto

    Curto Active Member

    Joined:
    Sep 4, 2003
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    NY, USA
    Ah yes, thankyou very much :)

    cPanel.net Support Ticket Number:
     
  11. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    No problem :D

    cPanel.net Support Ticket Number:
     
  12. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    Hi guys. I have a problem with the install script (i think).

    I have a few customers trying to install this. It's giving 1044 mysql errors on the install output in cPanel. I tried the install on multiple accounts. Same result. I tried the script posted here for updating and sure enough it looks great and works like the other version.. well same result. I can't get the thing to install and yes I have versions running that were installed fine a week or so ago and yes plenty of mySQL: db's on user account.

    any clues??

    cPanel.net Support Ticket Number:
     
  13. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    actually I just verified this on 4 servers, 5 domains. I get this error when loading the index page on the osc dir.

    1046 - No Database Selected

    select configuration_key as cfgKey, configuration_value as cfgValue from configuration

    cPanel.net Support Ticket Number:
     
  14. imagic

    imagic Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    16
    We're getting the exact same error on servers with the latest Edge release.

    On servers with WHM 7.4.2 cPanel 7.4.2-R158, no problem installing and the cart works great.

    Help!

    cPanel.net Support Ticket Number: 23425
     
  15. imagic

    imagic Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    16
    Here's the latest from Cpanel:
    Yes, this seems to be a bug, I'll forward this to the developers.

    Thank you.

    cPanel.net Support Ticket Number: 23425
     
  16. Curto

    Curto Active Member

    Joined:
    Sep 4, 2003
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    NY, USA
    me 2

    I'm getting the error:
    osCommerce Setup
    We are installing in /home/cownz/public_html/test... ERROR 1044: Access denied for user: 'cownz_osc2@localhost' to database 'cownz_osc2' Complete!

    When installing osCommerce in a normal account. The account is not a reseller.

    Any ideas?

    cPanel.net Support Ticket Number:
     
  17. imagic

    imagic Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    16
    Re: me 2

    Please open a ticket. Darkorb needs to know there are a lot of us with this problem so they will give it a higher priority to get it fixed.

    cPanel.net Support Ticket Number:
     
  18. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    I reportet a bug.. and here the reply:

    Hi,
    This is a bug that our developers are currently looking into. They hope to have this fixed soon. Thanks.

    cPanel.net Support Ticket Number:
     
  19. cPanelShanna

    cPanelShanna Staff Member
    Staff Member

    Joined:
    Jun 30, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    fixed in EDGE

    Date: Thu Sep 18 14:06:47 EDT 2003
    Build: 8.x Build#76
    Changes: fix a problem with addon script installs that use mysql

    cPanel.net Support Ticket Number:
     
  20. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
Loading...

Share This Page