thobarn

Well-Known Member
Apr 25, 2008
152
1
68
sanctum sanctorum
WHM 11.28.52 CENTOS 5.5 i686

Using Main >> Software >> Module Installers, installation is failed, not because the installation goes wrong but the *.so is copied to wrong place.

/usr/lib/php/extensions/no-debug-non-zts-20090626
instead of
/usr/local/lib/php/extensions/no-debug-non-zts-20090626

downloading memcache-2.2.6.tgz ...
Starting to download memcache-2.2.6.tgz (35,957 bytes)
..........done: 35,957 bytes
...

running: make INSTALL_ROOT="/root/tmp/pear-build-root/install-memcache-2.2.6" install
Installing shared extensions: /root/tmp/pear-build-root/install-memcache-2.2.6/usr/lib/php/extensions/no-debug-non-zts-20090626/
running: find "/root/tmp/pear-build-root/install-memcache-2.2.6" | xargs ls -dils
66489557 4 drwxr-xr-x 3 root root 4096 Mar 18 01:34 /root/tmp/pear-build-root/install-memcache-2.2.6
66489605 4 drwxr-xr-x 3 root root 4096 Mar 18 01:34 /root/tmp/pear-build-root/install-memcache-2.2.6/usr
66489606 4 drwxr-xr-x 3 root root 4096 Mar 18 01:34 /root/tmp/pear-build-root/install-memcache-2.2.6/usr/lib
66489607 4 drwxr-xr-x 3 root root 4096 Mar 18 01:34 /root/tmp/pear-build-root/install-memcache-2.2.6/usr/lib/php
66489608 4 drwxr-xr-x 3 root root 4096 Mar 18 01:34 /root/tmp/pear-build-root/install-memcache-2.2.6/usr/lib/php/extensions
66489609 4 drwxr-xr-x 2 root root 4096 Mar 18 01:34 /root/tmp/pear-build-root/install-memcache-2.2.6/usr/lib/php/extensions/no-debug-non-zts-20090626
66489604 192 -rwxr-xr-x 1 root root 192341 Mar 18 01:34 /root/tmp/pear-build-root/install-memcache-2.2.6/usr/lib/php/extensions/no-debug-non-zts-20090626/memcache.so

Build process completed successfully
Installing '/usr/lib/php/extensions/no-debug-non-zts-20090626/memcache.so'
install ok: channel://pecl.php.net/memcache-2.2.6
Extension memcache enabled in php.ini
The memcache.so object is not in /usr/local/lib/php/extensions/no-debug-non-zts-20090626
 
Last edited:

ckh

Well-Known Member
Dec 6, 2003
358
1
168
Phoenix, AZ
cPanel Access Level
DataCenter Provider
Go to the directory:

/usr/local/lib/php/extensions/no-debug-non-zts-20090626

then type:

ln -s /usr/lib/php/extensions/no-debug-non-zts-20090626/memcache.so

You now have a symlink pointing to the file and it should work fine. Found that out when installing the pecl imagemagick, does the same thing.
 

thobarn

Well-Known Member
Apr 25, 2008
152
1
68
sanctum sanctorum
thanks, I did copy the extension to the the right folder when I realized what was going on. posted here in case someone else has a similar problem.

out of curiosity, can what you suggested be done for the entire directory, ie. symlink /usr/local/lib/php/extensions/no-debug-non-zts-20090626 to /usr/lib/php/extensions/no-debug-non-zts-20090626?