The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP permission errors

Discussion in 'General Discussion' started by EMS, Jul 1, 2003.

  1. EMS


    May 10, 2003
    Likes Received:
    Trophy Points:

    I ran an apache update script yesterday as my server said I needed to as it was out of date and could be a security issue (I thought this was supposed to update automatically).

    After doing this I now get a few errors in some of my PHP pages. Mostly like this...

    Warning: fopen(filename.blah) [function.fopen]: failed to create stream: Permission denied in /home/blah/blah/public_html/blah.php(2) : eval()'d code on line 220

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/blah/blah/blah.php(2) : eval()'d code on line 221

    I checked this error out and it seems that since I ran the script - ownership on the file in question had gone to "99" and was set to 644

    I will admit to being a linux newbie - has anyone got any suggestions as to why this happened and what I need to do to fix it ? Support Ticket Number:

Share This Page