Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED PHP segfaults after 2018-1-25 EasyApache 4 update

Discussion in 'EasyApache' started by kris.x15, Jan 26, 2018.

  1. kris.x15

    kris.x15 Member

    Joined:
    Sep 20, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    51
    Hi
    I'm experiencing php segfaults (likely related to curl/openssl) when using imap_* functions since latest EasyApache 4 update (2018-1-25).

    Code:
    Jan 26 09:02:01 server1 kernel: [ 3444.689464] ea-php70[22118] general protection ip:7f9f0dfc611a sp:7ffd15575df0 error:0 in curl.so[7f9f0df31000+1d4000]
    Jan 26 09:02:02 server1 abrt[22128]: Saved core dump of pid 22118 (/opt/cpanel/ea-php70/root/usr/bin/php) to /var/spool/abrt/ccpp-2018-01-26-09:02:01-22118 (18374656 bytes)
    Jan 26 09:02:02 server1 abrtd: Directory 'ccpp-2018-01-26-09:02:01-22118' creation detected
    Jan 26 09:02:02 server1 abrtd: Package 'ea-php70-php-cli' isn't signed with proper key
    Jan 26 09:02:02 server1 abrtd: 'post-create' on '/var/spool/abrt/ccpp-2018-01-26-09:02:01-22118' exited with 1
    
    Updated kernel to latest version, tried other php binaries, versions - with the same outcome :(
     
  2. JacobPerkins

    JacobPerkins cPanel Product Owner

    Joined:
    May 2, 2014
    Messages:
    619
    Likes Received:
    96
    Trophy Points:
    103
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    We've had this report as well, and we've found some issues in our libc-client package when using IMAP-SSL functions in PHP. We've got a verified fix in place, we're doing our final testing now and will have this released in a few hours. Sorry for the problems, and thanks for the report!
     
  3. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,601
    Likes Received:
    64
    Trophy Points:
    328
    cPanel Access Level:
    Root Administrator
    Noticing this as well. Now I'm mad at myself because I looked on the forum for any reports, didn't see this post, and I've been pulling my hair out for the last 3 hours thinking the issue was some where within the (ugly) code I used for a specific application.

    Should have looked harder on the forum. I had to roll back the EA4 updates on one server. But otherwise, will wait for the fix.
     
  4. JacobPerkins

    JacobPerkins cPanel Product Owner

    Joined:
    May 2, 2014
    Messages:
    619
    Likes Received:
    96
    Trophy Points:
    103
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Howdy,

    We've pushed an update to fix these imap-ssl bindings. You should be able to get the update now.
     
  5. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,601
    Likes Received:
    64
    Trophy Points:
    328
    cPanel Access Level:
    Root Administrator
    Indeed. This looks to have solved the issue for me. Although I'm going to wait a bit before I push this out to our production servers, see if this fixes @kris.x15 issue as well.
     
  6. kris.x15

    kris.x15 Member

    Joined:
    Sep 20, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    51
    Same here - working after recent update.
    Thank you cPanel Team!


     
Loading...

Share This Page