SOLVED PHP Selector does not work anymore

moolideejay

Member
Nov 16, 2008
16
1
53
Hi

We have a cPanel server with CloudLinux 6.x and it was configured with php-selector and cpanel's multiphp was disabled via feature manager so users won't get confused. Everything was working perfectly until last night. Now all websites on the server run with the default php version on multiphp and php-selector's settings are completely ignored and all user's php settings have been lost.
I've provisioned EA4 multiple times with different options but that didn't help.

Is there anyway to disable MultiPHP on a cPanel server and only activate PHP-Selector?

cPanel v76.0.14
CloudLinux 6 x64
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,304
1,252
313
Houston
Hello @moolideejay


There is no way to disable cPanel's MultiPHP UI but that shouldn't be interfering with CloudLinux's PHP Selector. I do know that they pushed an update to the LVE Manager last night that was mildly problematic for some customers, though it wasn't specific to the issue you're experiencing. Re-Provisioning EasyApache won't help with this situation either, most likely. Do you happen to be running LSAPI? There was an issue about two days ago which is discussed here that did affect the PHP Selector EasyApache 4 2019-1-9: mod_lsapi reinstallation prevents Apache restart
 
  • Like
Reactions: moolideejay

moolideejay

Member
Nov 16, 2008
16
1
53
Yes, we use mod_lsapi. I guess I should change the PHP handler to the good old mod_SuPHP and see what happens.
 

moolideejay

Member
Nov 16, 2008
16
1
53
I've managed to fix the issue.
This is how I did it:
- Provisioned a new profile in EA4 (CloudLinux + All PHP Options + OpCache) which removed mod_lsapi and installed mod_suphp.
- Updated alt-php with #yum groupinstall alt-php

Apparently, mod_lsapi was causing the issue and removing it via provisioning a new profile in EasyApache fixed my problem.

Thank you cPanelLauren for suggesting the mod_lsapi.
 
  • Like
Reactions: cPanelLauren