gvard

Well-Known Member
PartnerNOC
Dec 22, 2003
211
9
168
Athens/GREECE
cPanel Access Level
DataCenter Provider
Hello,

Native PHP version has whatever is compiled via Easyapache. Native PHP is the PHP that is compiled through WHM, through PHP Selector you can select modules and/or options for PHP versions on the dropdown menu other than "native".
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,216
363
Hello :)

The message you see there is normal. Could you elaborate further on what you are attempting to change that is not working?

Thank you.
 

P_C

Registered
Aug 20, 2014
2
0
1
cPanel Access Level
Root Administrator
Hello everyone.
I'm having the same problem, trying to change my PHP version from 5.2.17 to 5.3.
Any help?
Many thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,216
363
Hello everyone.
I'm having the same problem, trying to change my PHP version from 5.2.17 to 5.3.
Any help?Many thanks!
Could you elaborate further on the specific issue you are having? For instance, do you mean the version of PHP you want to use is not available in the drop down field?

Thank you.
 

Cloud9

Well-Known Member
Sep 17, 2012
52
1
58
UK
cPanel Access Level
Root Administrator
Here is a printscreen of the issue.
Many thanks!View attachment 23261
Apart from CloudLinux - To have PHP selector enabled and running you need to install CageFS and then PHP selector on top of cloudlinux

CageFS

When CageFS is installed make sure you set it up for cpanel/whm and you need to enable it for all existing accounts (if desired) and also for all new accounts (if desired) or just some accounts

PHP Selector
 

24x7server

Well-Known Member
Apr 17, 2013
1,911
96
78
India
cPanel Access Level
Root Administrator
Twitter
I think suPHP is not compiled with LVE and due to that your are getting this issues, Can you please try to update this with the following command and check again.

Code:
# /usr/sbin/cpanel-compile-suphp.sh
# cagefsctl --force-update
 

hatem

Registered
Oct 4, 2015
1
0
1
Cairo
cPanel Access Level
Website Owner
Here is a printscreen of the issue

please i need ur help? i dont know what can i do?
i need to change my PHP from 5.2.17 to PHP 5.3.9.
Thank you
 

Attachments

Last edited by a moderator:

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
806
156
168
New Jersey
cPanel Access Level
DataCenter Provider
Hatem,

If you are just a website owner with strictly cPanel access, there is nothing this forum or you can do, you need to speak to your host.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,216
363
i need to change my PHP from 5.2.17 to PHP 5.3.9.
Hello :)

Yes, please let us know if you have root access, or contact your provider for additional assistance if you do not have root access to the system.

Thank you.