Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

php server api changed:

Discussion in 'General Discussion' started by admin0, Apr 9, 2006.

  1. admin0

    admin0 Active Member

    Joined:
    Aug 11, 2002
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    151
    Hi,

    I noticed someting in phpinfo.
    ServerAPI used to be Apache in all phpinfo before, but now I see CGI :eek: .

    What could trigger php from being changed from apache_module to CGI.


    How do I change it back ?

    recompiling apache via /scripts/easyapahe | WHM did not helped.

    maybe there are some special flags to toggle ?


    Thanks,
    :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. fwwebs

    fwwebs Well-Known Member

    Joined:
    Feb 16, 2004
    Messages:
    329
    Likes Received:
    0
    Trophy Points:
    166
    Apache was compiled with PHPSuexec
    Uncheck the PHPSuexec option in the Main >> Software >> Update Apache menu.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice