The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP set_include_path not working

Discussion in 'General Discussion' started by tomdchi, Mar 3, 2015.

  1. tomdchi

    tomdchi Well-Known Member

    Joined:
    Feb 24, 2008
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    cPanel Access Level:
    DataCenter Provider
    I recently changed my server to use DSO and mod_ruid2. I just noticed that set_include_path is not working. Is this because of DOS/mod_ruid2? If so, is there any way around it?

    I also tried setting a path in the .htaccess file but that didn't work either.
    Using PHP 5.4.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you open a support ticket using the link in my signature so we can take a closer look and attempt to reproduce the issue? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  3. RWH Tech

    RWH Tech Well-Known Member

    Joined:
    Oct 1, 2015
    Messages:
    74
    Likes Received:
    11
    Trophy Points:
    8
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    I'm having the same issue, on 11.52. What was the resolution?

    EDIT: found entries set in /usr/local/apache/conf/userdata/std/x/user/cp_php_magic_include_path.conf

    Where are those php_admin_value settings coming from?

    EDIT: Comes from PEAR Magic Loader. Magically breaking sites when enabled.
     
    #3 RWH Tech, Oct 9, 2015
    Last edited: Oct 10, 2015
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The resolution to the original poster was to disable "PHP Extensions and Applications Package Magic User Loader" via "WHM Home » Software » Module Installers » PHP Extensions and Applications Package", as you were able to determine.

    Thank you.
     
Loading...

Share This Page