Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP simplexml disabled

Discussion in 'EasyApache' started by phillbooth, Nov 23, 2016.

Tags:
  1. phillbooth

    phillbooth Active Member

    Joined:
    Sep 9, 2013
    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hello I need to get simplexml enabled I can see when I do a phpinfo '--disable-xml' '--disable-simplexml'

    I have php 5.6 and php 7 enable on my build but I can only run this website in 5.6 unfortunately.

    I have tried and easy apache rebuild and cannot see XML options anywhere, yet "yum" shows me that xml simple and xmlrpc is installed.


    php.ini output

    PHP Version 5.6.28
    Code:
    System    Linux myserver.com 3.10.0-229.20.1.el7.x86_64 #1 SMP Tue Nov 3 19:10:07 UTC 2015 x86_64
    Build Date    Nov 14 2016 15:28:16
    Configure Command    './configure' '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--program-prefix=' '--disable-dependency-tracking' '--prefix=/opt/cpanel/ea-php56/root/usr' '--exec-prefix=/opt/cpanel/ea-php56/root/usr' '--bindir=/opt/cpanel/ea-php56/root/usr/bin' '--sbindir=/opt/cpanel/ea-php56/root/usr/sbin' '--sysconfdir=/opt/cpanel/ea-php56/root/etc' '--datadir=/opt/cpanel/ea-php56/root/usr/share' '--includedir=/opt/cpanel/ea-php56/root/usr/include' '--libdir=/opt/cpanel/ea-php56/root/usr/lib64' '--libexecdir=/opt/cpanel/ea-php56/root/usr/libexec' '--localstatedir=/opt/cpanel/ea-php56/root/usr/var' '--sharedstatedir=/opt/cpanel/ea-php56/root/usr/com' '--mandir=/opt/cpanel/ea-php56/root/usr/share/man' '--infodir=/opt/cpanel/ea-php56/root/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib64' '--with-config-file-path=/opt/cpanel/ea-php56/root/etc' '--with-config-file-scan-dir=/opt/cpanel/ea-php56/root/etc/php.d' '--disable-debug' '--with-pic' '--enable-rpath=/opt/cpanel/ea-php56/root/usr/lib64' '--without-pear' '--with-bz2' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--with-vpx-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-sockets' '--with-kerberos' '--enable-shmop' '--enable-calendar' '--with-libxml-dir=/usr' '--enable-xml' '--with-system-tzdata' '--with-mhash' '--enable-dtrace' '--enable-fpm' '--with-fpm-systemd' '--libdir=/opt/cpanel/ea-php56/root/usr/lib64/php' '--without-mysql' '--disable-pdo' '--without-gd' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-opcache' '--disable-xmlreader' '--disable-xmlwriter' '--without-sqlite3' '--disable-phar' '--disable-fileinfo' '--disable-json' '--without-pspell' '--disable-wddx' '--without-curl' '--disable-posix' '--disable-xml' '--disable-simplexml' '--disable-exif' '--without-gettext' '--without-iconv' '--disable-ftp' '--without-bz2' '--disable-ctype' '--disable-shmop' '--disable-sockets' '--disable-tokenizer' '--disable-sysvmsg' '--disable-sysvshm' '--disable-sysvsem' 'build_alias=x86_64-redhat-linux-gnu' 'host_alias=x86_64-redhat-linux-gnu' 'CFLAGS=-O2 '-g' '-pipe' '-Wall' '-Wp,-D_FORTIFY_SOURCE=2' '-fexceptions' '-fstack-protector-strong' '--param=ssp-buffer-size=4' '-grecord-gcc-switches' '-specs=/usr/lib/rpm/redhat/redhat-hardened-cc1' '-m64' '-mtune=generic' '-fno-strict-aliasing' '-Wno-pointer-sign'' 'LDFLAGS=-Wl,-z,relro '-specs=/usr/lib/rpm/redhat/redhat-hardened-ld'' 'CXXFLAGS=-O2 '-g' '-pipe' '-Wall' '-Wp,-D_FORTIFY_SOURCE=2' '-fexceptions' '-fstack-protector-strong' '--param=ssp-buffer-size=4' '-grecord-gcc-switches' '-specs=/usr/lib/rpm/redhat/redhat-hardened-cc1' '-m64' '-mtune=generic''
    
     
    #1 phillbooth, Nov 23, 2016
    Last edited by a moderator: May 18, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You can disable this module for PHP 5.6 by editing the following file:

    Code:
    /opt/cpanel/ea-php56/root/etc/php.d/simplexml.ini
    It will look like this after editing the file to disable the module:

    Code:
    ; Enable simplexml extension module
    ; extension=simplexml.so
    Then, restart Apache:

    Code:
    /scripts/restartsrv_httpd
    Thank you.
     
  3. SunHunter

    SunHunter Member

    Joined:
    May 18, 2017
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Europe
    cPanel Access Level:
    Root Administrator
    I am having exactly the same problem as the original poster. The reply given above tells you how to *disable* the extension and not how to enable it. My phpinfo is pretty much the same as the OP, the important line as above is phpinfo '--disable-xml' '--disable-simplexml'

    How do you *enable* simplexml?

    Thank you (didn't want to create a duplicate post).
     
  4. SunHunter

    SunHunter Member

    Joined:
    May 18, 2017
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Europe
    cPanel Access Level:
    Root Administrator
    Solved my own problem. Not sure it's the correct way of things (or a permanent solution) but ran:

    yum install ea-php56-php-xml

    ... and has fixed the problem (when I run phpinfo the simplexml module is now loaded).

    Hope this helps someone else.
     
    cPanelMichael likes this.
Loading...

Share This Page