The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP Startup: Unable to load dynamic library

Discussion in 'General Discussion' started by Paulh267, Jan 22, 2016.

  1. Paulh267

    Paulh267 Registered

    Joined:
    Jan 22, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Has anyone else come across this repeated issue in their error logs? Mine is full of these two lines repeated (over 900 ,000 counts in just over a month):

    Code:
    [15-Jan-2016 08:18:27 America/Chicago] PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ixed.5.4.lin' - /opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ixed.5.4.lin: cannot open shared object file: No such file or directory in Unknown on line 0
    [15-Jan-2016 08:18:29 America/Chicago] PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php54/lib/php/extensions/no-debug-non-zts-20100525/imagick.so' - /opt/php54/lib/php/extensions/no-debug-non-zts-20100525/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0
    
    Does anyone know how you would go about fixing it?

    I had a look at this thread: PHP Warning: PHP Startup: Unable to load dynamic library no-debug-non-zts

    I think it might have something to do with 'Zend'. I have the following lines at the end of my php.ini file:

    Code:
    ;[Zend]
    ;zend_loader.enable=1
    ; Disable license checks (for performance reasons)
    ;zend_loader.disable_licensing=0
    ; The Obfuscation level supported by Zend Guard Loader. The levels are detailed in the official Zend Guard Documentation. 0 - no obfuscation is enabled
    ;zend_loader.obfuscation_level_support=3
    zend_extension = "/opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ZendGuardLoader.so"
    ;extension=pdo.so
    ;extension=pdo_sqlite.so
    ;extension=sqlite.so
    ;extension=pdo_mysql.so
    extension=imagick.so
    ;extension=magickwand.so
    extension="ixed.5.4.lin"
    
    Any help is appreciated :)
     
    #1 Paulh267, Jan 22, 2016
    Last edited by a moderator: Jan 22, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,829
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Is this issue isolated to an individual account? If so, have you reviewed the account to determine if any custom php.ini files are utilized?

    Thank you.
     
  3. Paulh267

    Paulh267 Registered

    Joined:
    Jan 22, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    I only have 1 account on the server so it should be that one. And yeah, we have a custom php.ini file, I had a search through it for '
    imagick.so' and found that Zend thing, which I don't remember adding. I'm wondering if anyone has come across it before?
     
  4. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello :),

    Yes. Check your /opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ directory, extension ixed.5.4.lin and imagick.so is not exist in that directory and due to that you are getting this error. If you have already installed these extension on your server then update correct path in your php.ini file.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,829
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You can try temporarily moving the php.ini file out of the way. EX:

    Code:
    cp -a /home/$username/php.ini /root/php.ini.backup
    Then, copy over the default php.ini file to the location of the php.ini file you moved, and make any custom changes that you require.

    Thank you.
     
Loading...

Share This Page