The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP stop working after I run /scripts/easyapache

Discussion in 'EasyApache' started by calvinphanctt, Apr 12, 2014.

  1. calvinphanctt

    calvinphanctt Active Member

    Joined:
    Mar 27, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Hello everyone,

    I am running WHM 11.42.1 (build 5) , on April 2nd, I run /scripts/easyapache to install PDO, SQLite3 ..

    after that couple of my websites on my dedicated server stop working. For example:

    1. For one website, when I click links on the menu on the left, it doesn't go to that link, it just stays on the same page ?


    2. On 1 of my other domain, I can't even get into the website with "Internal Server Error", and I checked error_log , it gives

    Code:
    [12-Apr-2014 18:49:01 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [12-Apr-2014 18:49:01 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [12-Apr-2014 18:49:01 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo_sqlite.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo_sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [12-Apr-2014 18:49:01 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/sqlite.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [12-Apr-2014 18:49:01 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo_mysql.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo_mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [12-Apr-2014 18:49:01 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/ixed.5.2.lin' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/ixed.5.2.lin: cannot open shared object file: No such file or directory in Unknown on line 0
    [12-Apr-2014 18:49:01 Europe/London] PHP Fatal error:  Directive 'allow_call_time_pass_reference' is no longer available in PHP in Unknown on line 0
    



    Here is my PHP info:

    Code:
    These PHP configuration settings are customizable by the server administrator. They are listed for reference only.
    
      Sub Section 	Directive 	Info 	Value
    Language Options 	asp_tags 	Allow ASP-style <% %> tags. 	Off
    File Uploads 	file_uploads 	Whether to allow HTTP file uploads. 	On
    Paths and Directories 	include_path 	Windows: "\path1;\path2" c:\php\includes" 	.:/usr/lib/php:/usr/local/lib/php
    Resource Limits 	max_execution_time 		30
    Resource Limits 	max_input_time 		60
    Resource Limits 	memory_limit 		32M
    Data Handling 	register_globals 	You should do your best to write your scripts so that they do not require register_globals to be on; Using form variables as globals can easily lead to possible security problems, if the code is not very well thought of. deprecated 	On
    Language Options 	safe_mode 	deprecated 	Off
    File Uploads 	upload_max_filesize 	Maximum allowed size for uploaded files. 	2M
    main 	session.save_path 	Argument passed to save_handler. In the case of files, this is the path where data files are stored. Note: Windows users have to change this variable in order to use PHP's session functions. As of PHP 4.0.1, you can define the path as: session.save_path = "N;/path" where N is an integer. Instead of storing all the session files in /path, what this will do is use subdirectories N-levels deep, and store the session data in those directories. This is useful if you or your OS have problems with lots of files in one directory, and is a more efficient layout for servers that handle lots of sessions. NOTE 1: PHP will not create this directory structure automatically. You can use the script in the ext/session dir for that purpose. NOTE 2: See the section on garbage collection below if you choose to use subdirectories for session storage 	/tmp
    So, please help me, tell me what did I do wrong ?

    Thank you very much !

    Sincerely,
    Calvin
     
  2. waleedrdc

    waleedrdc Registered

    Joined:
    Apr 12, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello

    I am sorry to hear about your issue but I would request you to check for any empty extension line in /usr/local/lib/php.ini

    In case you find any empty extension line (line without content after =) than comment out that line and restart apache.

    Hope this helps.
     
  3. calvinphanctt

    calvinphanctt Active Member

    Joined:
    Mar 27, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Hi Waleedrdc,

    Thank you for your suggestion, I look at my php.ini, I found they are empty at:
    disable_functions =
    disable_classes =
    auto_prepend_file =
    auto_append_file =
    doc_root =
    user_dir =
    mysql.default_socket =

    and I saw:
    ; register_globals = On ; deprecated (is this why it is not working?)

    By the way, how do I comment it out ? just put the ; in front of that line or ... ?

    Thank you.

    Sincerely,
    Calvin
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you check to see if your accounts are using custom php.ini files located within their home directories? If so, try disabling these files to see if that makes a difference.

    Thank you.
     
  5. calvinphanctt

    calvinphanctt Active Member

    Joined:
    Mar 27, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Hi Michael,

    At the moment I don't see any php.ini in the home directory , and there is no .htaccess either

    Last time I tried to create a php.ini or .htaccess to put
    register globals on

    But the website alsways give me "Internal Server Error"

    So could you please help?


    Thank you
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You could upload a "phpinfo" file to see which php.ini file is utilized. Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  7. calvinphanctt

    calvinphanctt Active Member

    Joined:
    Mar 27, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Hi Michael,

    I already upload phpinfo file, but how do I see which php.ini file is utilized?

    I don't want to open a support ticket since it costs $30 :(

    Please help me ! Thank you.

    Sincerely,
    Calvin
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Search the output of your "phpinfo" page for "php.ini" in your browser to see what shows up. Note there is no cost for complimentary support tickets if you are using a valid cPanel license.

    Thank you.
     
  9. calvinphanctt

    calvinphanctt Active Member

    Joined:
    Mar 27, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Hi Michael,

    I searched for "php.ini" and I got
    By the way my PHP Version is 5.4.27 now after I ran the easyapache

    Oh, of course I use license Cpanel and my web hosting company paid for it, but I don't know what the heck wrong with them, I made trouble ticket since April 12 and nobody answers over there.

    Thank you for your help!

    Sincerely,
    Calvin
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page