The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php suexec

Discussion in 'General Discussion' started by bofla, Jan 14, 2005.

  1. bofla

    bofla Member

    Sep 1, 2002
    Likes Received:
    Trophy Points:
    help ?

    damn ...
    did build apache from WHM, with php 4.3.10 and php suexec (selected also suexec), and now, all I get is premature end of script. no matter what I do, php script wont work. searched everywhere ... I have /usr/bin/php -v saying php 4.3.10 as (cgi), and just php -v saying (cli), when I comment out Loadmodule in apache, works fine, but php is running as nobody. The moment I comment Loadmodule and restart, php scripts wont run. I'm doing this for 2 hours, and nothing...heeeelp :eek:
    I've did everything as told. chmoded 755 on script, 777 on dir, user/group are the same, and it just keeps haunting me. I'm gonna dream "Premature end of script headers".
    and I get this for some files:
    [2005-01-14 20:53:32]: info: (target/actual) uid: (escustom/escustom) gid: (escustom/escustom) cmd: index.php
    [2005-01-14 20:53:32]: error: file has no execute permission: (/home/escustom/public_html/azpocbb/index.php)
    that doesn't work, permissions are 644
    but this file has 755
    [2005-01-14 20:52:42]: info: (target/actual) uid: (digital/digital) gid: (digital/digital) cmd: index.php
    and I get 500.
    it's driving me nuts !
    #1 bofla, Jan 14, 2005
    Last edited: Jan 15, 2005

Share This Page