The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Php update problem

Discussion in 'General Discussion' started by Malik, Apr 3, 2006.

  1. Malik

    Malik Member

    Joined:
    Dec 16, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    PHP not update.

    make: *** [sapi/cgi/php] Error 1
    make: *** Waiting for unfinished jobs....
    /usr/bin/ld: cannot find -lltdl
    collect2: ld returned 1 exit status
    make: *** [sapi/cli/php] Error 1

    make php-4.4.1...(install).... Done
    make: *** [sapi/cgi/php] Error 1


    Server:

    WHM 10.8.0 cPanel 10.8.1-C112
    Fedora i686 - WHM X v3.1.0

    Processor InformationProcessor #1 Vendor: GenuineIntel
    Processor #1 Name: Intel(R) Pentium(R) 4 CPU 3.00GHz
    Processor #1 speed: 3000.751 MHz
    Processor #1 cache size: 1024 KB

    Processor #2 Vendor: GenuineIntel
    Processor #2 Name: Intel(R) Pentium(R) 4 CPU 3.00GHz
    Processor #2 speed: 3000.751 MHz
    Processor #2 cache size: 1024 KB



    Memory InformationMemory: 1029344k/1048320k available (2233k kernel code, 18324k reserved, 836k data, 228k init, 130816k highmem)



    System InformationLinux 2.6.15-1.1833_FC4smp #1 SMP Wed Mar 1 23:56:51 EST 2006 i686 i686 i386 GNU/Linux



    Physcial Disks


    Current Memory Usage total used free shared buffers cached
    Mem: 1031020 985204 45816 0 38904 330304
    -/+ buffers/cache: 615996 415024
    Swap: 1052248 45936 1006312
    Total: 2083268 1031140 1052128



    Current Disk UsageFilesystem Size Used Avail Use% Mounted on
    /dev/sda2 2.0G 346M 1.5G 19% /
    /dev/sda1 99M 20M 74M 22% /boot
    /dev/shm 504M 0 504M 0% /dev/shm
    /dev/sda8 125G 24G 94G 21% /home
    /dev/sda7 996M 35M 910M 4% /tmp
    /dev/sda5 9.5G 2.7G 6.4G 30% /usr
    /dev/sda6 6.7G 1.6G 4.8G 25% /var
    /dev/sdb1 147G 50G 91G 36% /backup
    /tmp 996M 35M 910M 4% /var/tmp
     
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Try to update php from shell :-
    1) Login to server.
    2) /scripts/easyapache
    3) Select 7th option.
    4) Select php version.
    5) Exit and Save

    Let the script execute and restart apache
    service httpd stop
    service httpd start

    If you still receive any errors, paste it.
     
  3. Malik

    Malik Member

    Joined:
    Dec 16, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    l -lz -lz -lcrypt -lcrypt -o sapi/cgi/php
    /usr/bin/ld: cannot find -lltdl
    collect2: ld returned 1 exit status
    make: *** [sapi/cgi/php] Error 1
    initfpsuexec: using apache 1.x support
    PHP version file has been updated to 4.4.1
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd start: httpd started
    Waiting for httpd to restart..............finished.

    root 27278 2.1 0.8 12092 9040 ? Ss 20:47 0:00 /usr/local/apache/bin/httpd -DSSL

    httpd started ok

    in php info old config at (Build Date Mar 25 2006 02:22:16)
     
  4. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Execute the below command and paste the o/p :-
    locate ltdl
     
  5. Malik

    Malik Member

    Joined:
    Dec 16, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    root@ns1 [/scripts]# locate ltdl
    warning: locate: could not open database: /var/lib/slocate/slocate.db: No such file or directory
    warning: You need to run the 'updatedb' command (as root) to create the database.
    Please edit /etc/updatedb.conf to enable the daily cron job.
    root@ns1 [/scripts]#
     
  6. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    The above error is for the locate command. Execute the below command :-
    ]# updatedb
    ]# locate ltdl

    Paste the o/p.
     
  7. Malik

    Malik Member

    Joined:
    Dec 16, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    root@ns1 [/scripts]# locate ltdl
    /usr/lib/libltdl.so.3.1.1
    /usr/lib/libltdl.so.3
    /usr/share/libtool/libltdl
    /usr/share/libtool/libltdl/install-sh
    /usr/share/libtool/libltdl/config.guess
    /usr/share/libtool/libltdl/config-h.in
    /usr/share/libtool/libltdl/README
    /usr/share/libtool/libltdl/ltdl.h
    /usr/share/libtool/libltdl/aclocal.m4
    /usr/share/libtool/libltdl/Makefile.in
    /usr/share/libtool/libltdl/config.sub
    /usr/share/libtool/libltdl/Makefile.am
    /usr/share/libtool/libltdl/configure.ac
    /usr/share/libtool/libltdl/ltmain.sh
    /usr/share/libtool/libltdl/configure
    /usr/share/libtool/libltdl/COPYING.LIB
    /usr/share/libtool/libltdl/ltdl.c
    /usr/share/libtool/libltdl/acinclude.m4
    /usr/share/libtool/libltdl/missing
    /usr/share/aclocal/ltdl.m4
    /var/cache/yum/updates-released/packages/libtool-ltdl-1.5.16.multilib2-3.i386.rpm
    /var/cache/yum/updates-released/headers/libtool-ltdl-1.5.16.multilib2-3.i386.hdr
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl/aclocal.m4
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl/README
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl/config-h.in
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl/Makefile.am
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl/ltdl.h
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl/ltdl.c
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl/COPYING.LIB
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl/Makefile.in
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl/acinclude.m4
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl/configure.in
    /home/cpapachebuild/buildapache/libmcrypt-2.5.7/libltdl/configure
    root@ns1 [/scripts]#
     
  8. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Now do the following :-
    cp /usr/lib/libltdl.so.3 /usr/lib/libltdl.so
    and compile php again as per my first post.
     
  9. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    Better way to do it is

    ln -s /usr/lib/libltdl.so.3 /usr/lib/libltdl.so
     
  10. Malik

    Malik Member

    Joined:
    Dec 16, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Has helped. Many thanks.
     
  11. nadavoid

    nadavoid Member

    Joined:
    Sep 11, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I am following this procedure, and still getting essentially the same error as mentioned earlier.
    Code:
    make: *** [sapi/cgi/php] Error 1
    make [@php-5.2.1]...(install).................Done
    make: *** [sapi/cgi/php] Error 1
    I am not getting the ltdl related error, so that's not the particular issue.

    I have verbose output enabled, so the output is about a mile long. Should I post it here, inside a "CODE" tag?
     
  12. nadavoid

    nadavoid Member

    Joined:
    Sep 11, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    nevermind. Verbose showed me that it was a problem with the postgres php extension. I'll head down that track now.
     
  13. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Did you ever find out how to fix this?
     
  14. nadavoid

    nadavoid Member

    Joined:
    Sep 11, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Here is what I did

    The essence of the problem I think was that the pgsql php extension would not work with php 5.2.3. Fortunately, using an older version of the extension worked fine. Here are the steps I used. I highly recommend trying it on a development server first, before doing it on a live production server.

    0- locate an older version of pgsql. One way to get it is to upgrade/downgrade to php 5.2.0, and grab the pgsql extension files from here:
    /home/cpapachebuild/buildapache/php-5.2.3/ext/pgsql
    ... copy them into your home directory. for the sake of this example, that is here:
    /home/someone/src/php-pgsql/pgsql

    1- upgrade apache/php WITHOUT selecting the PostgreSQL option

    (command-line / shell from here on out.)

    2- (quick) cp -rfpd /home/someone/src/php-pgsql/pgsql /home/cpapachebuild/buildapache/php-5.2.3/ext/pgsql

    3- cd /home/cpapachebuild/buildapache/php-5.2.3

    4- ./configure '--with-xsl' '--with-apxs=/usr/local/apache/bin/apxs' '--prefix=/usr/local' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-dom' '--with-dom-xslt' '--with-dom-exslt' '--enable-exif' '--with-swf=/usr/local/flash' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-gettext' '--with-imap=/usr/local/imap-2004g' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-mcrypt' '--with-mhash' '--enable-magic-quotes' '--with-mysqli' '--with-mysql=/usr' '--with-openssl' '--enable-discard-path' '--with-pear' '--with-pspell' '--enable-xslt' '--with-xslt-sablot' '--enable-sockets' '--enable-track-vars' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--enable-versioning' '--enable-wddx' '--with-xmlrpc' '--with-zip' '--with-zlib' '--with-pgsql=/usr'

    (that's the configure command that was just run (get it from a phpinfo()), but you add '--with-pgsql=/usr' at the end.)

    5- make clean; make; make test; make install; /etc/init.d/httpd configtest; /etc/init.d/httpd restart

    Yes, quite the pain. I don't know if this is still necessary however, with the latest buildapache script in cpanel 11, and so many updated sources.
     
Loading...

Share This Page