Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

php upgarde problem

Discussion in 'General Discussion' started by xml, Jul 27, 2010.

  1. xml

    xml Well-Known Member

    Joined:
    Jan 15, 2004
    Messages:
    85
    Likes Received:
    1
    Trophy Points:
    158
    hello all

    i upgraded yester day my server php from 5.2.10 to 5.2.14 and since then some of my vbulletin forums can not be browsed, instead its acting like dowloadable files when i click it as shown in the attached image.

    did i make somthing wrong when upgraded php? is there any bugs in php5.2.14 can couse that?, the problem i cant roll back to php5.2.10 its not there any more in apache build.
     

    Attached Files:

  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,429
    Likes Received:
    415
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I would think you have at least a couple options here.
    The first one, go back to the EA3 page and leave the default option there ticked, "Previously Saved Config" and rebuild Apache.
    Or, Go thru all your settings again reselect all the options you'd like and rebuild.
    Or, click the Basic (if your previous build has failed, please use this option) and rebuild.

    PHP is not being parsed so the websites pages are asking to be downloaded instead of viewed.

    Meantime, I suggest password protection on the account(s) if possible, block all users till you get Apache back up and running properly.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. xml

    xml Well-Known Member

    Joined:
    Jan 15, 2004
    Messages:
    85
    Likes Received:
    1
    Trophy Points:
    158
    i found that my .htaccess under the www folder is missing and i think it might be the couse of the problem, what should i write inside .htaccess file exactly to make php files work preperly ?
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice