php: /usr/lib/libmysqlclient.so.14: version `libmysqlclient_14' not found (required b

A

aisagtr

Guest
I searched all over the forum and none of the suggestions seems to work. Submitted a ticket but no reply to date.

I have a new RHE5 box and installed cpanel 11 from scratch.

Everything went well but php files are being downloaded instead of parsed.

Anyway, tried everything from upcp --force to recompiling Apache but php -v still shows:

php: /usr/lib/libmysqlclient.so.14: version `libmysqlclient_14' not found (required by php)

I checked and the libmysqlclient.so.14 is there in the directory where it is supposed to be.

Tried a manual install of php 5.2.4 but its returning error with unable to compile.

I am trying to install php 5.*.* on Apache 2.0

Any advise please?
 
A

aisagtr

Guest
Manual installation of php 5.2.4 will return this error:

Sorry, I cannot run apxs. Possible reasons follow:

1. Perl is not installed
2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
3. Apache was not built using --enable-so (the apxs usage page is displayed)

The output of /usr/local/apache2/bin/apxs follows:
./configure: line 6669: /usr/local/apache2/bin/apxs: No such file or directory
configure: error: Aborting