The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php: /usr/lib/ version `libmysqlclient_14' not found (required b

Discussion in 'General Discussion' started by aisagtr, Oct 27, 2007.

  1. aisagtr

    aisagtr Guest

    I searched all over the forum and none of the suggestions seems to work. Submitted a ticket but no reply to date.

    I have a new RHE5 box and installed cpanel 11 from scratch.

    Everything went well but php files are being downloaded instead of parsed.

    Anyway, tried everything from upcp --force to recompiling Apache but php -v still shows:

    php: /usr/lib/ version `libmysqlclient_14' not found (required by php)

    I checked and the is there in the directory where it is supposed to be.

    Tried a manual install of php 5.2.4 but its returning error with unable to compile.

    I am trying to install php 5.*.* on Apache 2.0

    Any advise please?
  2. aisagtr

    aisagtr Guest

    Manual installation of php 5.2.4 will return this error:

    Sorry, I cannot run apxs. Possible reasons follow:

    1. Perl is not installed
    2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
    3. Apache was not built using --enable-so (the apxs usage page is displayed)

    The output of /usr/local/apache2/bin/apxs follows:
    ./configure: line 6669: /usr/local/apache2/bin/apxs: No such file or directory
    configure: error: Aborting
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Nov 29, 2006
    Likes Received:
    Trophy Points:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    What was the ticket ID number?

Share This Page