The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP Version 4.4.2, register_globals ON php.ini no longer works!

Discussion in 'General Discussion' started by sh4ka, Jun 2, 2006.

  1. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    I just have register_globals Off for the entire server.. but i had it enabled for some users that need that ON, then just created a php.ini file in the webroot and wrote:

    register_globals = On

    And it was working perfectly, until i upgraded apache with webroot protection + safe mode + suEXEC, and then it no longer works as it was in PHP 4.3.11

    Any ideas ??
     
  2. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    Created .htaccess with "php_value register_globals 1" on the webroot, and fixed :D .

    ThkZ!
     
Loading...

Share This Page