The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP web form not submitting info after server transfer?!?

Discussion in 'General Discussion' started by linearfusion, Sep 1, 2006.

  1. linearfusion

    linearfusion Member

    Joined:
    Aug 31, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    We have hundreds of PHP forms which are now inactive which we believe to be the result of migrating our websites from one server to another.

    They are currently running the same versions of PHP however the original O/S was Redhat (linux kernal 3.2.3-20) and now the sites are deployed on Fedora Core 4.

    The form sends, however there is not any information. They are simple forms which had been working before the server migration such as:

    {



    $email = "Name:\t$faq_name\nPhone Number:\t$faq_phonenumber\nEmail:\t$faq_email\nProblem location:\t$faq_location\nDescription:\t$faq_description\nComments:\t$faq_comm ents\n\n";

    $to = "test@test.com";

    $subject = "Problem with the Building Request Form";

    mail($to, $subject, $email);

    include("thanks.php");

    }


    Any ideas?!? All questions, comments, suggestions, fixes greatly appreciated!!!

    HELP!!!!
     
  2. SonServers

    SonServers Well-Known Member

    Joined:
    Oct 24, 2001
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    This is just a guess . . . is register_globals turned off in php.ini on the new server? If so, the form may not be getting the data.
     
  3. oblaims

    oblaims Registered

    Joined:
    Sep 2, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    php mailer needed

    pls can u help me with php mailer
     
  4. gflamerich

    gflamerich Well-Known Member

    Joined:
    Jul 21, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Have you set this on?
    In WHM at "Tweak Settings" you will find an option that says:

    Prevent the user "nobody" from sending out mail to remote addresses (PHP and CGI scripts generally run as nobody if you are not using PHPSuexec and Suexec respectively.)

    That could be the reason of your problem.
     
Loading...

Share This Page