php4 and Zend - issue with include()

EWD

Well-Known Member
PartnerNOC
Aug 19, 2003
165
0
166
NY
Hi Guys,

I am running a server with php4.4.7 and zend.
It is setup with SuPHP and if zend is installed and you try to use include() in a file you get an internal server error.
error log just shows premature end of script headers.

Anyone else having this issue and/or know a fix other then disable zend opt?

Thanks ;)
 

darren.nolan

Well-Known Member
Oct 4, 2007
257
0
66
Seen this error on 4.4.6 as well as 4.4.7 - Happened after installing Zend.

My problem was from clients trying to include ('http://theirdomain.com/theirscript.php'); rather than relative to their script include ('./directory/file.php');

Settings in PHP.ini for URL open and the such didn't not work. No idea on a solution, and I haven't found one yet. As a PHP programmer though, it's good practice to not use a domain in an include if you can avoid it.
 

EWD

Well-Known Member
PartnerNOC
Aug 19, 2003
165
0
166
NY
Thanks for the tip. It helped ;)