Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Php5.1, Zend and ioncube

Discussion in 'General Discussion' started by docjohn, Apr 14, 2006.

  1. docjohn

    docjohn Member

    Joined:
    Aug 30, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    151
    Hi folks,

    I needed php5.1 for an application on my server, but since upgrading ioncube loader no longer works properly. I followed the instructions at this thread:

    http://forums.cpanel.net/showthread.php?t=48505&highlight=php5

    to install the right version of Zen (2.6.2), but used WHM to install the Php5.1 version. All of that went fine.

    I get this error whenever I run a php script now:

    Failed loading /usr/local/ioncube/ioncube_loader_lin_4.3.so: /usr/local/ioncube/ioncube_loader_lin_4.3.so: undefined symbol: zend_hash_add_or_update

    I downloaded the latest ioncube loaders from their site as well, tried 4.4 as well as 4.3, and tried the ioncube loader that comes with cpanel, but nothing seems to work.

    Any suggestions? Thanks!
    John
     
  2. mousepotatoe

    mousepotatoe Active Member

    Joined:
    Dec 17, 2003
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    156
    If ioncube gives you issues, I have found simply uploading the ioncube foder into your public_html folder will allow ioncube to run properly with php5 and zend
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tolra

    tolra Active Member

    Joined:
    Mar 4, 2006
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    151
    You need the 5.1 ioncube loaders not the 4.x.

    In your php.ini you'll have something like:

    zend_extension=/opt/ioncube/ioncube_loader_lin_4.3.so

    You need to change it to:

    zend_extension=/opt/ioncube/ioncube_loader_lin_5.1.so

    Note: The paths will be different for you, they should point to where you unpacked the latest version of the loaders.
     
  4. docjohn

    docjohn Member

    Joined:
    Aug 30, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    151
    So obvious in hindsight, yet I was completely missing this! Duh!!

    Changed the version number of the loader as suggested and it now works like a charm.

    Thank you very much for your help.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice