The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP5 and PostgreSQL

Discussion in 'General Discussion' started by ieris, Mar 12, 2010.

  1. ieris

    ieris Registered

    Joined:
    Oct 28, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello!
    Can anyone suggest how to resolve the problem of enabling PostgreSQL to work with PHP5?

    PostgreSQL is installed and running:
    root@localhost [/var/tmp]# rpm -qa |grep postg
    postgresql-python-8.1.18-2.el5_4.1
    postgresql-libs-8.1.18-2.el5_4.1
    postgresql-8.1.18-2.el5_4.1
    postgresql-server-8.1.18-2.el5_4.1
    root@localhost [/var/tmp]# ps -ef|grep postg
    postgres 25099 1 0 Feb16 ? 00:00:02 /usr/bin/postmaster -p 5432 -D /var/lib/pgsql/data
    postgres 25101 25099 0 Feb16 ? 00:00:03 postgres: logger process
    postgres 25104 25099 0 Feb16 ? 00:00:11 postgres: writer process
    postgres 25105 25099 0 Feb16 ? 00:00:00 postgres: stats buffer process
    postgres 25106 25105 0 Feb16 ? 00:00:00 postgres: stats collector process


    When building EasyApache with PHP5 and pgsql I got:
    -- Begin opt 'PGsql' --
    -- Begin dryrun test 'Check postgresql' --
    -- End dryrun test 'Check postgresql' --

    -- Begin dryrun test 'Check postgresql for PHP 5' --
    dryrun test 'Check postgresql for PHP 5' did not return true

    !! Dry run failed for 'Cpanel::Easy::PHP5::Pgsql' skipping option !!


    Regards, Martin
     
  2. ieris

    ieris Registered

    Joined:
    Oct 28, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Problem was solved installing postgres-devel.

    Thanks goes to CPanel support.
     
Loading...
Similar Threads - PHP5 PostgreSQL
  1. durangod
    Replies:
    2
    Views:
    218

Share This Page