The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP5 not compiling with fcgi using EasyApache

Discussion in 'EasyApache' started by HemanthJ, Feb 28, 2012.

  1. HemanthJ

    HemanthJ Member

    Joined:
    Feb 28, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
  2. HemanthJ

    HemanthJ Member

    Joined:
    Feb 28, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks for moving the thread to the correct category. But is there any rules against posting images?
     
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I've seen no PHP options available before due to WHM > Tweak Settings > Max cPanel Process Memory being set too low (set it to 512 or 1024 rather than 256). After bumping up that value, go to WHM > Apache Configuration > PHP and SuExec Configuration area to see if you then show the PHP handler options.

    If you do not, next run this command in root SSH:

    Code:
    php -v
    You'll see if there happens to be a syntax error or issue with your /usr/local/lib/php.ini file that might be preventing the handlers from being set.
     
  4. HemanthJ

    HemanthJ Member

    Joined:
    Feb 28, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks mate. Yesterday I raised a support ticket and James resolved the issue. As you pointed out the cPanel memory limit was the culprit.

    Please consider adding this to the documentation and in the WHM section where we change the PHP handler.

    Cheers,
    Hemanth
     
Loading...

Share This Page