The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP5 not detecting php.ini in user's home dir

Discussion in 'General Discussion' started by a_raims, Jun 14, 2006.

  1. a_raims

    a_raims Member

    Joined:
    Feb 10, 2006
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    PHP4 and PHP5.0.5 is installed in server and both are working great.
    But php5 is not detecting php.ini file in user's home directory. PHPsuexec is
    enabled with both php4 and php5.

    Any help is appreciated..:)
     
  2. Mysteerie

    Mysteerie Well-Known Member

    Joined:
    Dec 29, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    Having the same the problem as well. php 5.1.4 with phpsuexec.
     
  3. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    This thread http://forums.cpanel.net/showthread.php?t=53185& says

    I have it on my list of things to try the next time I need a custom php.ini. The custom one has to be in the directory of the exception, not above it as rights do not transfer down the directory tree.
     
  4. ispro

    ispro Well-Known Member

    Joined:
    Apr 8, 2004
    Messages:
    628
    Likes Received:
    1
    Trophy Points:
    18
  5. Onyx

    Onyx Member

    Joined:
    May 28, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    After testing a number of options it seems that PHP 5.1.4 does not fully support custom php.ini files. Don't know whether this is a bug or a change in the direction of PHP, but I truly needed per-directory php.ini support. Downgrading PHP to 5.0.5 fixed this problem and all is well. I haven't tested per-home-directory but I would imagine this works as well. Of course a custom wrapper is probably the best way to go for flexibility on shared hosting, but downgrading is a good temporary fix should you not need the latest PHP.
     
  6. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    hi ispro, i did follow your instructions and also have the wrapper, but with 5.1.4 is not working that wrapper.

    Any idea how to get it working?

    Thank you!
     
  7. ispro

    ispro Well-Known Member

    Joined:
    Apr 8, 2004
    Messages:
    628
    Likes Received:
    1
    Trophy Points:
    18
    I have not much time to debug it. However check the wrapper for custom php.ini input. Perhaps commandline params were changed in 5.1.4 (in past it was -c param). Check it.

    Perhaps later I will take a look.
     
  8. Francisco

    Francisco Well-Known Member

    Joined:
    Jun 3, 2003
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    any news on this?


    Having this problem as well, and I only need to enable register_globals for one account. :eek:
     
  9. Earendil

    Earendil Well-Known Member

    Joined:
    Jun 10, 2004
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16
    I believe it's related to this bug:

    http://bugs.php.net/bug.php?id=33882

    Which was included in PHP5.
    No current workaround, although I have been told that it should work with suPHP (in beta atm) instead of phpSuExec
     
Loading...
Similar Threads - PHP5 detecting php
  1. durangod
    Replies:
    2
    Views:
    217

Share This Page