php5 problems with xml incomplete upgrade install

eeadmin

Well-Known Member
Oct 21, 2004
69
0
156
Dallas, TX
I am having a problem with XML functionality in PHP5. A lot of the old XML functionality from php4 went out the window. It seems like many of the new functionality works just fine, but I am having problem with one of the new classes XSLTProcessor can not be found. Anybody have any idea what that means.

Some back ground

phpinfo

php version 5.0.4
configure command:
'./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-dom' '--with-dom-xslt' '--with-dom-exslt' '--enable-ftp' '--enable-magic-quotes' '--with-mysql' '--enable-discard-path' '--with-pear' '--enable-xslt' '--with-xslt-sablot' '--enable-sockets' '--enable-track-vars' '--enable-versioning' '--with-zlib'

IS it possible one of the module addons are not up to date? That is the only thing I can think of after messing with this for a day.
 

Kerstin

Well-Known Member
Apr 9, 2005
136
0
166
Berlin
Maybe be your installed XML-Parser not walking correct.

Reinstall XML parser-package in the system registered path :confused:

usr/local/apache/bin/apxs