The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Php_value

Discussion in 'General Discussion' started by coderoyal, Jun 27, 2006.

  1. coderoyal

    coderoyal Well-Known Member

    Joined:
    Mar 8, 2005
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Hi everyone,


    I am trying to compile Apache with Curl support, but when I accomplish this, I run into another issue which affects everyone that is using the Gallery product on their websites. I can compile apache with no difficulty, and even with Curl, but everytime I recompile Apache, using the WHM "update apache" section, the gallery stops working!

    Basically, users are presented with the 500 internal server error page.

    The error log reveals the following error in the apache error log:

    Invalid command 'php_value', perhaps mis-spelled or defined by a module not included in the server.

    The Gallery software intalls in the .htaccess file the following:

    php_value post_max_size 20971520
    php_value upload_max_filesize 20971520
    php_value magic_quotes_gpc off
    php_value session.save_handler files
    php_value register_globals off


    It's entirely possible that I'm not checking in the needed apache option under the build page. Does anyone know which option I need to choose, in order to compile apache to support the php_value function? I thought it was just a part of PHP itself, but that doesn't appear to be the case.

    PHP itself works, as all other PHP code on websites is processed.

    I'd like to be able to compile new options into apache, such as curl, but I can't until I can do it without affecting the gallery software.

    Does anyone have any experience with this?

    Thanks!
    Alan
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Sounds like you have phpsuexec enabled.

    If so, PHP doesn't run as an Apache module and therefore any PHP-related settings in .htaccess files will be meaningless to Apache to the point where it simply gives up and goes home (your HTTP 500 errors).

    Remove the PHP-based settings from the relevant .htaccess file and Apache will be happy. Pop the required settings in a local php.ini file and that should be that.

    If you still have problems, search these forums for phpsuexect - you'll find plenty of information on what you need to do to get PHP scripts to execute correctly under phpsuexec (I posted a quick checklist once which covers the main issues).
     
  3. coderoyal

    coderoyal Well-Known Member

    Joined:
    Mar 8, 2005
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Hi! Hmm.... I guess this means that I can just be sure that phpsuexec isn't enabled? I was probably choosing that as an option and shouldn't have been. It would probably be too much to ask the customers to modify their .htaccess file just for phpsuexect. I'll try compiling again today without that feature.

    Thanks for your help!
     
  4. coderoyal

    coderoyal Well-Known Member

    Joined:
    Mar 8, 2005
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    I made sure phpsuexec wasn't selected, compiled, and it worked!

    Thanks for your help!
     

Share This Page