Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

phpinfo disabled but it's not in disable_functions

Discussion in 'General Discussion' started by smatt, Jul 28, 2016.

  1. smatt

    smatt Active Member

    Joined:
    Apr 28, 2016
    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    london
    cPanel Access Level:
    Root Administrator
    Hi all,

    I've removed phpinfo from the disable_functions in the php.ini file (done through WHM's PHP config editor).

    I go to the phpinfo page but it still says it's disabled. I restarted Apache, no change. I rebooted the server, no change. phpinfo is not listed in disable_functions (after reboot). Is there another setting somewhere to enable/disable this?

    And on a related note but different note, I'm a little confused as to what should be in the disable_functions list. Most guides/tutorials say to put ini_set in there, but then common CMSs like Drupal won't work. Enable it on a per account basis, or for just within their own environment without opening a security risk?

    Any help on either appreciated.
     
  2. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    391
    Likes Received:
    4
    Trophy Points:
    168
    Did you disable it in the correct php.ini file? Please check phpinfo() for the exact location of that file.
     
  3. smatt

    smatt Active Member

    Joined:
    Apr 28, 2016
    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    london
    cPanel Access Level:
    Root Administrator
    I can't check phpinfo(), it is disabled...!

    I'm trying to enable it. I removed it from disable_functions using WHM's PHP Configuration Editor. Verified the change was saved on CLI with grep phpinfo /usr/local/lib/php.ini - no result.
     
  4. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    391
    Likes Received:
    4
    Trophy Points:
    168
    Sorry smatt, I thought it was the other way around. php.ini is usually located @ /usr/local/lib/
     
  5. smatt

    smatt Active Member

    Joined:
    Apr 28, 2016
    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    london
    cPanel Access Level:
    Root Administrator
    ^ No problem. Any ideas on how to fix?
     
  6. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    391
    Likes Received:
    4
    Trophy Points:
    168
    You may need to view the php.ini file manually (via vi or pico) to see if it's actually overwritten. Sometimes there are multiple lines of disabled_functions
     
  7. smatt

    smatt Active Member

    Joined:
    Apr 28, 2016
    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    london
    cPanel Access Level:
    Root Administrator
    Yes I thought that might be the case too - checked for that, only one disable_functions row, phpinfo is definitely not there.
     
  8. smatt

    smatt Active Member

    Joined:
    Apr 28, 2016
    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    london
    cPanel Access Level:
    Root Administrator
  9. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice