The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpmailer script authenticates mail but exim does not permit delivery

Discussion in 'E-mail Discussions' started by calvarystudio, Jun 15, 2016.

  1. calvarystudio

    calvarystudio Registered

    Joined:
    Jun 15, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    KENYA
    cPanel Access Level:
    Root Administrator
    Hi,

    I have a mailing script on my client's server who is trying to use an account in webmail to send mail. The authentication process works as indicated by the output of the script and the server gets the email into its queue but when I check the delivery report, the mail was not delivered to the sender.

    Debug from phpmailer script
    Code:
    2016-06-16 03:59:22    Connection: opening to localhost:25, t=300, opt=array (
                                             )
    2016-06-16 03:59:22    Connection: opened
    2016-06-16 03:59:22    SERVER -> CLIENT: 220-mail.XXX.tk ESMTP Exim 4.87 #1 Thu, 16 Jun 2016 06:59:22 +0300
                                             220-We do not authorize the use of this system to transport unsolicited,
                                             220 and/or bulk e-mail.
    2016-06-16 03:59:22    CLIENT -> SERVER: EHLO example.com
    2016-06-16 03:59:22    SERVER -> CLIENT: 250-mail.XXX.tk Hello XXX.com [::1]
                                             250-SIZE 52428800
                                             250-8BITMIME
                                             250-PIPELINING
                                             250-AUTH PLAIN LOGIN
                                             250-STARTTLS
                                             250 HELP
    2016-06-16 03:59:22    CLIENT -> SERVER: AUTH LOGIN
    2016-06-16 03:59:22    SERVER -> CLIENT: 334 VXNlcm5hbWU6
    2016-06-16 03:59:22    CLIENT -> SERVER: d2ViLW5vdGlmaWNhdGlvbnNAdGhlYmVkZWxsZS5jb20=
    2016-06-16 03:59:22    SERVER -> CLIENT: 334 UGFzc3dvcmQ6
    2016-06-16 03:59:22    CLIENT -> SERVER: V0JlbGxlTm90aWYyMDE1
    2016-06-16 03:59:22    SERVER -> CLIENT: 235 Authentication succeeded
    2016-06-16 03:59:22    CLIENT -> SERVER: MAIL FROM:<reservations@XXX.com>
    2016-06-16 03:59:22    SERVER -> CLIENT: 250 OK
    2016-06-16 03:59:22    CLIENT -> SERVER: RCPT TO:<XXX@XXX.tk>
    2016-06-16 03:59:22    SERVER -> CLIENT: 250 Accepted
    2016-06-16 03:59:22    CLIENT -> SERVER: DATA
    2016-06-16 03:59:22    SERVER -> CLIENT: 354 Enter message, ending with "." on a line by itself
    2016-06-16 03:59:22    CLIENT -> SERVER: Date: Thu, 16 Jun 2016 06:59:22 +0300
    2016-06-16 03:59:22    CLIENT -> SERVER: To: XXX@XXX.tk
    2016-06-16 03:59:22    CLIENT -> SERVER: From: The XXX- Reservations <reservations@XXX.com>
    2016-06-16 03:59:22    CLIENT -> SERVER: Reply-To: reservations@XXX.com
    
    2016-06-16 03:59:22    CLIENT -> SERVER: Message-ID: <bfc0b5a2d7fb6bb19d42ff2a3faeffff@example.com>
    2016-06-16 03:59:22    CLIENT -> SERVER: X-Priority: 3
    2016-06-16 03:59:22    CLIENT -> SERVER: X-Mailer: PHPMailer 5.2.9 (https://github.com/PHPMailer/PHPMailer/)
    2016-06-16 03:59:22    CLIENT -> SERVER: MIME-Version: 1.0
    2016-06-16 03:59:22    CLIENT -> SERVER: Content-Type: text/html; charset=iso-8859-1
    2016-06-16 03:59:22    CLIENT -> SERVER: Content-Transfer-Encoding: 8bit
    2016-06-16 03:59:22    SERVER -> CLIENT: 250 OK id=1bDOSg-001IfX-3w
    2016-06-16 03:59:22    CLIENT -> SERVER: QUIT
    2016-06-16 03:59:22    SERVER -> CLIENT: 221 mail.XXX.tk closing connection
    2016-06-16 03:59:22    Connection: closed
    Then checking the mail delivery, I get this
    Code:
    ECDHE-RSA-AES256-GCM-SHA384:256 CV=no: SMTP error from remote mail server after RCPT TO:<XXX@XXX.tk>: 550-Please turn on SMTP Authentication in your mail client.\n550-XXX.XXX.tk [XXX.63.13.XXX]:55176 is not permitted
     
    #1 calvarystudio, Jun 15, 2016
    Last edited by a moderator: Jun 16, 2016
  2. calvarystudio

    calvarystudio Registered

    Joined:
    Jun 15, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    KENYA
    cPanel Access Level:
    Root Administrator
    I found the solution by setting 'Restrict outgoing SMTP to root, exim, and mailman (FKA SMTP Tweak) to OFF'. What would be the implications?
     
  3. kdean

    kdean Well-Known Member

    Joined:
    Oct 19, 2012
    Messages:
    262
    Likes Received:
    12
    Trophy Points:
    18
    Location:
    Orlando, FL
    cPanel Access Level:
    Root Administrator
    If you're connecting via SMTP to Exim you shouldn't have to disable that feature.

    One thing to try. You're sending via port 25, try sending via port 587 which requires authentication and may pass muster with the receiving server.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page