SOLVED phpMyAdmin AuthenticationCpanel.php Error

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
Hello,

To update, here's the response from the support ticket noting the solution:

Code:
You should now be able to access phpmyadmin when logging into the 'user123' account when using the password again. In order to get this working, I ended up manually setting the password for the 'user123' through mysql:

=====
set password for 'user123'@'localhost' = PASSWORD(' [ PASSWORDHERE ] ');
flush privileges;
=====

After doing this, I verified that I could access phpmyadmin when logging into the 'user123' cPanel account using the password.  Then, I changed the password for this account and verified I could access phpmyadmin when logging in using the new password.  Finally, I switched the 'user123' back to the original password and verified that I could still access phpmyadmin when logging into the 'user123' cPanel account using the password.

Thank you,
Thank you.
 

Metro2

Well-Known Member
May 24, 2006
473
49
178
USA
cPanel Access Level
Root Administrator
Just in case this is helpful / relevant to others... just a couple of notes regarding some user accounts unable to load phpMyAdmin from cPanel:

I had previously thought that maybe this issue stemmed from accounts being migrated from old server to new server (as I mentioned in my previous post on first page of this thread) but - have since discovered that it seems to happen randomly / to random accounts occasionally, regardless of whether they were migrated from an existing previous account / server or if they've been created within past year on same server.

There was a time when I could resolve this by just updating the DB User password for a DB in cPanel (even using the same password) for example - on a WordPress site I could examine wp-config.php and copy the password from it, go to their cPanel > Databases > DB Users and use the change password function and just re-enter same password and Save, and that would fixed it. But that method hasn't worked in a long time.

The only thing that consistently resolves this issue is changing their actual cPanel password. (I do it though WHM > Account Functions because it's convenient, but it can be done in SSH command line of course).

I can't seem to determine any pattern or reason as to why it happens. It's very random. Could have 200 accounts on a server and randomly this will happen with just a couple of accounts here & there. Sporadic.

Thankfully the easy fix is to just change their cPanel password. This no big deal to us of course, but for some users you'd think it was the end of the world having to tell them their cPanel password has been updated ;)
 

j.centeno

Registered
Aug 18, 2020
1
0
1
Philippines
cPanel Access Level
Root Administrator
First of all, thank you for sharing a couple of solutions and a little bit of info as to why this issue occurs.

The first solution, which is to change the password using the "WHM>Password Modification" method, did not work for me.

The second solution, which is to directly change the MySQL password for the cpanel user worked for me.

But the question still remains: Why did this happen?

Also, for this particular user where the problem occurred there is still an issue. Yes, it works when I change the MySQL password using shell, but when I then again try to change the cpanel password using the "WHM>Password Modification" method, it won't synchronize.

Thank you very much!
-Jeremy