Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

PHPMyAdmin broke last night

Discussion in 'Database Discussion' started by cwalke32477, Feb 24, 2011.

  1. cwalke32477

    cwalke32477 Well-Known Member

    Joined:
    Mar 2, 2010
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Atlanta, Georgia
    cPanel Access Level:
    Root Administrator
    Last night my phpMyAdmin, server wide, has become broken.
    Customers cannot expoert, or import databases.
    On import it gives the following error: (unfortunatekay, I do not have an export error handy)
    import.php: Missing parameter: import_type (FAQ 2.8)
    import.php: Missing parameter: format (FAQ 2.8)

    I checked to make sure php.ini had a good upload size setting.
    Any ideas on how to fix this?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,609
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello,

    Please re-save WHM > Tweak Settings to ensure it is properly saving the values, since sometimes incorrect values in Tweak Settings for the "cPanel PHP max upload size" or the "cPanel PHP max POST size" can cause these errors in PhpMyAdmin.

    Of note, the php.ini cPanel uses for PhpMyAdmin would not be the global one /usr/local/lib/php.ini but one of these:

    /usr/local/cpanel/3rdparty/etc/php.ini
    /usr/local/cpanel/3rdparty/etc/phpmyadmin/php.ini

    Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cwalke32477

    cwalke32477 Well-Known Member

    Joined:
    Mar 2, 2010
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Atlanta, Georgia
    cPanel Access Level:
    Root Administrator
    It was tweak settings where I set the file size limit.
    However, the issue is resolved. It was not an issue with phpymadmin,
    but an issue with a full /tmp partition. A good lesson for any admin to watch his
    /tmp.
    I have arecitified any further /tmp occurrances by adding a cron for tmpwatch

    # crontab -e
    Add the follwing line
    0 5 * * * tmpwatch --mtime 5 /tmp
    -This will run at 5AM each morning, and delete /tmp files older than 5 hours, wihtout hurting a current mysql socket.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice