The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpMyAdmin broken?

Discussion in 'Database Discussions' started by burstlag, Mar 7, 2006.

  1. burstlag

    burstlag Registered

    Mar 6, 2006
    Likes Received:
    Trophy Points:
    phpMyAdmin broken? [solved]


    I recently installed cPanel 10.8.0 on FreeBSD 5.3. This is a brand new server with only one test domain on it. Everything seems to work okay for the most part, but clicking on the phpMyAdmin links in the WHM or cPanel only returns a blank page with no URL in the addressbar when using Mozilla. Konqueror does display a URL ( and pops up an error message saying that connection to the host was broken. MySQL appears to be running just fine on the server.

    I searched the forms and FAQ and neither had any matches for "phpmyadmin". Where should I start troubleshooting?

    Update: I found the apache config file in /usr/local/apache/conf/ and bumped the LogLevel all the way up to debug. When I clicked on the phpMyAdmin link, nothing at all was logged to any file in /usr/local/apche/logs. Most perplexing.

    Update 2: Ah, now we're getting somewhere. In /usr/local/cpanel/logs, I found:
    /usr/libexec/ Shared object "" not found, required by "php"
    I didn't see anything about PAM in the installation instructions. Where do I go from here?

    Update 3: Fixed it by doing:
    ln -s /usr/local/lib/compat/ /usr/local/lib/
    If there's a better solution, I'm all ears.
    #1 burstlag, Mar 7, 2006
    Last edited: Mar 7, 2006

Share This Page