The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpMyAdmin cannot upload or import databases.

Discussion in 'Database Discussions' started by furtif, Feb 1, 2010.

  1. furtif

    furtif Member

    Joined:
    Aug 17, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Sorry for my english.

    I have a problem with phpMyAdmin during import of sql files.

    In fact, i have this error message when i start the import.

    "Aucune données n'a été reçu en vue de l'importation. Aucun nom de fichier n'a été fourni, ou encore la taille du fichier a dépassé la limite permise par votre configuration de PHP. "

    In english, i thinks is :
    "No data has been received for import. No filename
    has been provided, or the file size exceeded the limit
    by your PHP configuration."

    But, my php configuration accept a size file of 50m.

    Please, do you have any solution for this problem ?

    Thanks a lot
     
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    phpMyAdmin uses it's own php.ini saved under

    Change the upload limit in the above file and try to import the sql file once again.
     
  3. furtif

    furtif Member

    Joined:
    Aug 17, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    Thanks for your answer.

    I have look into this configuration file, but i don't thinks that is the origin of problem.

    Code:
    file_uploads    = On                            ; Whether to allow HTTP file uploads
    upload_tmp_dir  = /tmp                  ; temporary directory for HTTP uploaded files (will use system default if not specified)
    upload_max_filesize = 128M

    Code:
    post_max_size = 128M
    My sql file take 8ko.

    Do you have an other idea for this problem ?

    Thanks a lot
     
  4. bamm

    bamm Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    same issue here

    Did you ever figure this out?

    I'm having the same issue. The file I'm trying to import is only 402kb and the post max size in php.ini is set to 8mb

    Thanks for any help.
     
  5. Graywolfie

    Graywolfie Member

    Joined:
    Oct 14, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    This same issue began for me today also. I import a csv file daily. It did not work today and resulted in the error. I tried the same file that worked yesterday and it also did not work.

    Increasing values in the php.ini file has no positive effect.

    A separate thrid party program for managing MySQL databases allowed the file to be imported without issue.

    The problem must be with a very recent change to cPanel/phpMyAdmin.

    Looking forward to a fix.

    (EDIT) FYI - the file in question is only 276KB. The process has worked fine for nearly 2 years. Something broke...
     
  6. eastitaly

    eastitaly Member

    Joined:
    Feb 18, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here

    cPanel 11.25.0-R43470 (RELEASE tree)
     
  7. Maat

    Maat Registered

    Joined:
    Dec 18, 2007
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    Problem solved for me

    Hello all,

    I had the same problem today : with the root password, no problem to import a file in PhpMyAdmin but error when trying with a user password.

    I solved the problem changing the line in the file /usr/local/cpanel/3rdparty/etc/phpmyadmin/php.ini :

    "; upload_tmp_dir ="
    TO
    "upload_tmp_dir = /tmp"
     
    mohit likes this.
  8. Utkman

    Utkman Registered

    Joined:
    Feb 18, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    This fix worked perfectly for me -thanks.
     
  9. Graywolfie

    Graywolfie Member

    Joined:
    Oct 14, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Making this change in the php.ini file did not work for me. Also, import does not work whether logged in as root or not.

    Any other suggestions?

    (EDIT) - I should clarify; I modified the file located at /usr/local/lib and then restarted apache. The change shows up in the phpinfo script located on the domain in question. Should I attempt to modifiy the file listed above? and if so, will the changes stick?
     
    #9 Graywolfie, Feb 18, 2010
    Last edited: Feb 18, 2010
  10. mohit

    mohit Well-Known Member

    Joined:
    Jul 12, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sticky On Internet
    Thanks, Maat, you solved my problem.

    Graywolfie, you need to edit the php.ini file which is used for phpmyadmin
    as said by Maat.

    pico /usr/local/cpanel/3rdparty/etc/phpmyadmin/php.ini
     
  11. Maat

    Maat Registered

    Joined:
    Dec 18, 2007
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    Hello all,

    The problem is here again after the Cpanel update. I just contact the Cpanel Support....
    I'll keep you informed.
     
  12. Graywolfie

    Graywolfie Member

    Joined:
    Oct 14, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Thanks Maat and Mohit for the advice. Since I currently have a workaround I'll monitor the comments here.

    It will be better to have a proper fix than a band-aid on the issue. Anyone who wants to use the import option should not need to edit the php.ini file first. Whatever broke it in the first place needs to be undone.

    I'm just happy to know it wasn't just me having the issue. ;)
     
  13. Maat

    Maat Registered

    Joined:
    Dec 18, 2007
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    I had an answer from Cpanel support :

    - Edit the file as said in my previous post
    - Run "/scripts/makecpphp" to fix the php.ini
    - Try a "/scripts/upcp" to test if the file is still correct after the update

    That should do it.
     
  14. eastitaly

    eastitaly Member

    Joined:
    Feb 18, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Maat's latest post seems to solve the problem for me [ tested on cPanel 11.25.0-R43471 (RELEASE tree) ]
     
  15. cPanelGregK

    cPanelGregK Administrator
    Staff Member

    Joined:
    Sep 8, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    phpMyAdmin Upload Issue

    We are aware of an issue where uploads of sql dumps via phpMyAdmin are failing, due to the lack of a setting for upload_tmp_dir.

    To correct ths issue, edit /usr/local/cpanel/3rdparty/etc/phpmyadmin/php.ini and change

    Code:
     'upload_tmp_dir '
    to

    Code:
    'upload_tmp_dir  = /tmp '
     
  16. Data 1

    Data 1 Well-Known Member

    Joined:
    May 25, 2008
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Columbus Ohio
    cPanel Access Level:
    DataCenter Provider
    And restart apache?
     
  17. macrunning

    macrunning Member

    Joined:
    Feb 19, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Update Issue

    Yesterday there were some cPanel updates to our servers and we have been told by our hosting company that the cPanel updates are causing a problem with us not being able to upload/update our databases using phpmyadmin within the individual domains. We need to be able to upload our sql statements for our websites on a daily basis. This has never been an issue in the more than 5 years I have been with my hosting company or using the whm/cpanel setup.

    When we try to upload our sql statement thru the phpmyadmin for a particular website we get the following message:
    ""No data was received to import. Either no file name was submitted, or the file size exceeded the maximum size permitted by your PHP configuration.""

    I have checked the php ini file in whm and everything appears fine. By the way, we have not changed anything previous to this problem. We can log in thru whm to update the databases with our sql files but this is not a good solution for us. We have written automation scripts which update the databases on individual domains that sit on this server regularly. We have 2 dedicated servers as well that are both affected by this problem.

    Our hosting company is telling us that cPanel will look into the matter. I would appreciate it if cPanel would look into this bug and provide an ETA on this as we need to update many databases on many different websites.

    cPanel if you require more information from us on this issue please let us know. Thank you.
     
  18. thufael

    thufael Registered

    Joined:
    Feb 8, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bangalore,India
    cPanel Bug with phpmyadmin

    I've found a fix for this

    Edit the php.ini file of phpmyadmin, ie /usr/local/cpanel/3rdparty/etc/phpmyadmin/php.ini and edit the section which says

    upload_tmp_dir

    change it to

    upload_tmp_dir = /tmp

    It works like a charm.
     
  19. rageracer

    rageracer Member

    Joined:
    Feb 19, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    This did not work.
     
  20. rageracer

    rageracer Member

    Joined:
    Feb 19, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    phpMyAdmin 3.2.4 import error after cPanel Upgrade

    Checked everything in FAQ 1.16 and all is set OK.

    post_max_size 8M
    memory_limit 32M
    upload_max_filesize 2M

    upload_tmp_dir /tmp

    What the heck happened? :(
     
Loading...

Share This Page