Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

phpMyAdmin doesn't start - gives a session error

Discussion in 'Database Discussion' started by SoftDux, Apr 17, 2008.

  1. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    991
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    Hi all

    This is a new installation on a VPS, and when I launch phpMyAdmin, I get the following error:

    According to php.ini the session_save_path = /tmp & /tmp is writable by everyone. I've deleted all the files from /tmp as well, but it still doesn't work. Any other suggestions?
     
  2. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    166
    Did you try restarting cpanel? Had a check of the cpanel error logs?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    991
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    Yes. I've rebooted the VPS as well, same thing

    Yes, no clues here either. /var/log/messages doesn't give me any errors either. From what I have seen from google search results, it has todo with the session_save_path not being writable, but it is, and there's a lot of user's session files in there.
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,216
    Likes Received:
    10
    Trophy Points:
    313
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Logs relating to cpsrvd (the daemon that serves cPanel, WHM and Webmail) are typically found in /usr/local/cpanel/logs with exception of the update logs.

    /var/log/messages is only for IMAP, POP3 and SpamAssassin, thus you would not find any entries there regarding the phpMyAdmin being served by cpsrvd.
     
  5. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    991
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    ok, so where / how do I find out why it's causing this problem then?
     
  6. k3oni

    k3oni Member

    Joined:
    Nov 2, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Somewhere is USA
    Sometimes if you login in to PHPMYADMIN, you can see the error as follows.

    Cannot start session without errors, please check errors given in your PHP and/or webserver log
    file and configure your PHP installation properly.

    FIX:

    Check permissions of /tmp. It should be 755. Change it to 1777. Now access PHPMYADMIN.

    /usr/local/cpanel/3rdparty/etc/phpmyadmin/php.ini

    Change session.save_path as /tmp and restart apache.

    Have a Smile :)
     
  7. Warrenw

    Warrenw Active Member
    PartnerNOC

    Joined:
    Nov 1, 2008
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    51
    Using K3oni response with slight change I solved the same problem:

    view /usr/local/cpanel/3rdparty/etc/phpmyadmin/php.ini and see what session.save_path is already set to and make the permissions changes on that file. 1777 is not required 1755 worked as well.

    Ownership of the file in the session.save_path must also be set to phpmyadmin phpmyadmin
     
    #7 Warrenw, May 3, 2009
    Last edited: May 3, 2009
  8. corpresa

    corpresa Active Member

    Joined:
    Jan 16, 2009
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Barcelona
    thank you

    Thank you, k3oni and all the people that help to resolv this problema :)
    I was a big help
     
  9. mitgib

    mitgib Well-Known Member
    PartnerNOC

    Joined:
    Apr 9, 2006
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    156
    I had changed the session.save_path to /tmp several times on one of our servers, and upcp reverts it to /var/cpanel/userhomes/cpanelphpmyadmin/sessions, which didn't exist on this server, so a quick and easy work around I used was

    Code:
    mkdir -p /var/cpanel/userhomes/cpanelphpmyadmin/sessions
    chmod 1777 /var/cpanel/userhomes/cpanelphpmyadmin/sessions
    
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    168
    Setting to 1777 did not work for me, and I also had no user phpmyadmin, but I symlinked sessions to /tmp and that seems to be working.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice