The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpmyadmin don't show tables for one database

Discussion in 'Database Discussions' started by panoinka, Jan 11, 2012.

  1. panoinka

    panoinka Registered

    Joined:
    Mar 4, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    A customer create a database in CPanel, and ask to me help him to restore a backup for that DB.
    I restore the backup using this command:
    mysql user_database < backup.sql

    Using mysql, I can manipulate all the tables and register, the same using the web aplication.

    The problem is when I try to use phpmyadmin to manipulate that database, phpmyadmin don't show any table, I create a new table to see if is listed, but nothing; also when I try to download a backup of that database (using CPanel Backups tool), the backup it's empty.

    All the rest of databases are working fine with phpmyadmin.
    Any have an idea about this issue?
     
  2. storminternet

    storminternet Well-Known Member

    Joined:
    Nov 2, 2011
    Messages:
    462
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Please try to repair database with the command mysqlcheck -r databasename and check if that fix the problem.
    If not then try to restore it again with same of different backup (if you have multiple backups).
     
  3. panoinka

    panoinka Registered

    Joined:
    Mar 4, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Thank you for the answer, but not working that solution for me.

    The solution that I found.
    I'll check the backup, and it have a predefined user, I create that user in the mysql database, and the phpmyadmin show me the tables for that database.
     
Loading...

Share This Page