The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PhpMyAdmin error 500 on https connection from self signed certificate

Discussion in 'Database Discussions' started by MrVon, Nov 11, 2011.

  1. MrVon

    MrVon Member

    Joined:
    Nov 3, 2011
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    WHM 11.30.4 (build 6)
    phpMyAdmin-3.4.7.1
    I have account created without CGI access
    i created sub domain in cPanel sub.site.com
    I have generated SSL certificate in WHM for host sub.site.com
    i installed it by selecting site and it loaded values except last one
    now i unzipped phpMyAdmin and trying to access by
    http://sub.site.com/phpMyAdmin -> works!
    https://sub.site.com/phpMyAdmin -> error 500!
    apache detail log:
    HTML:
    [Fri Nov 11 16:17:15 2011] [error] [client 99.52.118.86] Premature end of script headers: index.php
    [Fri Nov 11 16:17:15 2011] [error] [client 99.52.118.86] File does not exist: /home/myaccount/public_html/sub/500.shtml
    [Fri Nov 11 16:17:15 2011] [error] [client 99.52.118.86] SoftException in Application.cpp:422: Mismatch between target UID (99) and UID (504) of file "/home/myaccount/public_html/sub/phpMyAdmin/index.php"
    
     
    #1 MrVon, Nov 11, 2011
    Last edited: Nov 11, 2011
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If I may ask, why are you trying to install your own version of PHPMyAdmin when cPanel provides this as part of the product itself?

    As for the error, it indicates permissions issues between the user nobody and the account user:

    The issue is likely that the SSL is installed as the user nobody when you are trying to run the files as the actual username. Since you are using suPHP, the files being run must run as the right user. Therefore, you cannot have the SSL installed as the nobody user for that set subdomain but must have it installed as that user.
     
  3. MrAndreas

    MrAndreas Member

    Joined:
    Oct 31, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Reason why i install phpMyAdmin separately is because my current installation does not allow importing zip files and i dont want to have headache of changing it right now.
    Besides i have created account for someone else whom wont have access to cPanel of that account, only ftp, yet he needs access to database so i thinking better that than give him cPanel password.

    And just as matter of making this phpMyAdmin data safe from interception i want to enable SSL.
    Now when i have created certificate for sub admin e.g. "sub.site.com" and select it by using browse button in "Main >> SSL/TLS >> Install a SSL Certificate and Setup the Domain" and use account username - i have error.

    Code:
    SSL install aborted due to error: Sorry, you must have a dedicated ip to  use this feature for the user: mysite.com!  If you are intending to  install a shared certificate you must use the username "nobody" for  security and bandwidth reporting reasons.
    Thats why i used "nobody". Even though my server already has dedicated ip by default, its just when i created this account i did not select dedicated ip option. Is there way to override this error and install certificate for account username? or change ownership of certificate with chown command (in this case where i find files)?
     
    #3 MrAndreas, Nov 14, 2011
    Last edited: Nov 14, 2011
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You would need to install a dedicated IP on that account in order to use this feature for https for PHPMyAdmin for that user's account and then re-install the SSL certificate for that account.
     
  5. MrVon

    MrVon Member

    Joined:
    Nov 3, 2011
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Can i do that and then change account back to non dedicated ip? ;)
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    A dedicated IP address is required for accounts that use SSL certificates. Changing the account's IP address to a shared IP address would result in the certificate not working properly.

    Thank you.
     
Loading...

Share This Page